Bug 635411 - Auto-login in LXDE live CD is no good for non-US English config
Auto-login in LXDE live CD is no good for non-US English config
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: LXDE F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-09-19 11:19 EDT by Adam Williamson
Modified: 2010-10-28 16:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-19 11:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2010-09-19 11:19:57 EDT
When you boot the LXDE live CD it's configured to auto-login, which is great if the default settings are right for you, but not much use if you want to use any language and keyboard layout other than English. Like the other spins, it should present a login manager to give you an opportunity to change language and keymap settings before logging in.

We treat not handling i18n stuff like this a a blocker in the other spins where the design is already intended to handle it, but I think for LXDE this is more like an enhancement request than anything else, because the process simply hasn't been designed for this. So I'm going to propose treating it as an RFE and a nice-to-have for F14 Final rather than a blocker as it would be in another spin.
Comment 1 Adam Williamson 2010-09-19 11:20:11 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Christoph Wickert 2010-09-19 11:37:39 EDT
I think we are facing two problems:

1. Keyboard layout selection should be applied instantly so you can already use it for username and password

2. For the autologin case we should have a configurable timeout, say 20 seconds to select session, keyboard and language.

I consider this more a feature request, therefor it should be tracked in upstream's bug tracker. I forwarded you request to 
https://sourceforge.net/tracker/?func=detail&aid=3071309&group_id=180858&atid=894869

Thanks for your report.
Comment 3 Christoph Wickert 2010-09-19 11:39:27 EDT
BTW: IMO this should not be a target F14. We don't have all the language packs on the spins anyway and I intentionally left system-config-language on the LXDE livecd.
Comment 4 Adam Williamson 2010-09-19 12:06:21 EDT
OK. I kinda figured the autologin configuration happened on the Fedora end, though, not upstream? Shouldn't LXDM provide configuration parameters for this and Fedora just set the ones it likes? (I guess adding those parameters would be an upstream job if they don't already exist, though.)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Christoph Wickert 2010-09-19 13:09:17 EDT
Sorry, it was not clear what you were proposing, therefor I considered
everything to be taken care of by upstream. From your private message I now know you want to have a login manager, where you can select language and session and perhaps even keyboard layout.

I don't think having a login manager it is a good idea for LXDE though:
- We don't have a way to set a default username, so people would have to
fill in "liveuser"
- People would hit return on an empty password. This is confusing.

People wont know how to login, therefor it will add more problems than it actually solves.
Comment 6 Adam Williamson 2010-09-19 17:17:03 EDT
Honestly, the solution sounds more and more like 'lxdm sucks, dump it'. :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.