Bug 635613 - cdrom is auto ejected after loading ata_piix driver while install rhel39 on rhel55kvm
cdrom is auto ejected after loading ata_piix driver while install rhel39 on r...
Status: CLOSED DUPLICATE of bug 652135
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-09-20 06:34 EDT by slei
Modified: 2011-09-22 06:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 04:55:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the image loading ata_piix driver (11.30 KB, image/png)
2010-09-20 06:34 EDT, slei
no flags Details

  None (edit)
Description slei 2010-09-20 06:34:01 EDT
Created attachment 448416 [details]
the image loading ata_piix driver

Description of problem:
cdrom is auto ejected after loading ata_piix driver while install rhel39 on rhel55kvm

Version-Release number of selected component (if applicable):

uname -r        2.6.18-221.el5
rpm -q kvm      kvm-83-198.el5

How reproducible:
1 、run the following command:
/home/autotest/client/tests/kvm/qemu \
-name 'vm1' \
-monitor stdio \
-drive file='/home/autotest/client/tests/kvm/images/win2008-32.qcow2',index=0,if=ide,media=disk,cache=none,format=qcow2 \
-net nic,vlan=0,model=rtl8139,macaddr='02:B8:C4:E7:45:33' \
-net tap,vlan=0,ifname='rtl8139_0_8000',script='/home/autotest/client/tests/kvm/scripts/qemu-ifup-vbr0',downscript='no' \
-m 2048 \
-smp 2 \
-drive file='/home/autotest/client/tests/kvm/isos/ISO/Win2008/32/en_windows_server_2008_datacenter_enterprise_standard_x86_dvd_X14-26710.iso',media=cdrom,index=1 \
-drive file='/home/autotest/client/tests/kvm/isos/windows/winutils.iso',media=cdrom,index=2 \
-cpu qemu64,+x2apic \
-soundhw ac97 \
-fda '/home/autotest/client/tests/kvm/images/floppy.img' \
-redir tcp:5000::10023 \
-vnc :0 \
-spice port=8000,disable-ticketing \
-qxl 1 \
-rtc-td-hack \
-M rhel5.5.0 \
-usbdevice tablet \
-boot d

2、run "info block" to check the cdrom status,you will find that there are two cdrom :ide0-cd1 and ide1-cd0 inserted before loading  ata_piix  driver

3、after loading ata_piix driver ,you will find that the ide1-cd0 uninserted.

  
Actual results:


Expected results:


Additional info:
Comment 3 RHEL Product and Program Management 2011-01-11 15:52:22 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 17:53:10 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 6 Markus Armbruster 2011-08-08 11:37:55 EDT
We've fixed a bunch of CD-ROM issues since this one was reported, e.g. bug 652135.  Could you retest?
Comment 7 Golita Yue 2011-09-22 03:54:04 EDT
[On host kvm-83-199.el5]
Tested 10 time with guest rhel3.9-32 & rhel3.9-64, cannot reproduce it
# uname -r
2.6.18-221.el5

etherboot-roms-kvm-5.4.4-13.el5
kvm-debuginfo-83-199.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-83-199.el5
kmod-kvm-83-199.el5
kvm-tools-83-199.el5
kvm-qemu-img-83-199.el5

The block info always displays like the following:
(qemu) info block
ide0-hd0: type=hd removable=0 file=/home/gyue/r3.9.qcow2 ro=0 drv=qcow2
ide0-cd1: type=cdrom removable=1 locked=0 file=/tmp/linux/RHEL3.9-x86_64-DVD.iso ro=1 drv=raw
ide1-cd0: type=cdrom removable=1 locked=0 file=/home/gyue/ks-64bit.iso ro=1 drv=raw
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]
The ide1-cd0 was inserted during whole installation of guest rhel3.9.

[On host kvm-83-236.el5]
Tested 10 time with guest rhel3.9-32 & rhel3.9-64, didn't hit this bug too.
# uname -r
2.6.18-243.el5

etherboot-roms-kvm-5.4.4-13.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-83-236.el5
kmod-kvm-83-236.el5
kvm-tools-83-236.el5
kvm-qemu-img-83-236.el5
kvm-debuginfo-83-236.el5

The ide1-cd0 was inserted during whole installation of guest rhel3.9.
Comment 8 Markus Armbruster 2011-09-22 04:55:30 EDT
We can't reproduce anymore (comment#7).  Bug must have been fixed along with bug 652135.

*** This bug has been marked as a duplicate of bug 652135 ***

Note You need to log in before you can comment on or make changes to this bug.