Bug 635768 - livecd-creator doesn't create bootable initrd in iso
livecd-creator doesn't create bootable initrd in iso
Status: CLOSED DUPLICATE of bug 624028
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-20 12:33 EDT by David Brown
Modified: 2010-10-28 20:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 20:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpm -qa output (12.02 KB, text/plain)
2010-09-20 12:34 EDT, David Brown
no flags Details

  None (edit)
Description David Brown 2010-09-20 12:33:43 EDT
Description of problem:
    livecd-creator when creating the minimal iso doesn't create a kernel and initrd pair that works on the iso. The iso boots fine however it can't find the LiveCD root file system at all.


Version-Release number of selected component (if applicable):
livecd-tools-033-3.fc13.x86_64
libudev-153-3.fc13.x86_64
udev-153-3.fc13.x86_64
lvm2-2.02.73-2.fc13.x86_64
lvm2-libs-2.02.73-2.fc13.x86_64
dracut-005-3.fc13.noarch
fedora-kickstarts-0.13.5-1.fc13.noarch

How reproducible:
Install livecd-tools and fedora-kickstarts then try to build an iso using the fedora-live-mini.ks file provided by fedora-kickstarts. Then boot the created iso in virt-manager

Steps to Reproduce:
1. sudo yum install livecd-tools fedora-kickstarts
2. sudo livecd-creator -c /usr/share/spin-kickstarts/fedora-live-mini.ks
  
Actual results:
    LiveCD boots then pauses for a time, then spits out a short message about not being able to fine the root file system.

Expected results:
    LiveCD should have booted and provided a tty prompt.

Additional info:
    I did some digging and found that the updated version of udev seemed to have some issues with this. A work around is to back level udev to the original fedora13 release with out applying the updates. It seems like udev isn't seeing the loopback labels properly, I think.

I can see a couple of fixes for this:
 1. the dracut initrd needs to be created so that it can find the LiveCD root file system without depending on udev labels to do so.
 2. udev needs to be fixed to recognize loop device labels again.
Comment 1 David Brown 2010-09-20 12:34:55 EDT
Created attachment 448507 [details]
rpm -qa output

This is the full rpm -qa output from the iso build box.
Comment 2 Fedora Admin XMLRPC Client 2010-10-21 13:57:43 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Brian Lane 2010-10-28 20:48:48 EDT

*** This bug has been marked as a duplicate of bug 624028 ***

Note You need to log in before you can comment on or make changes to this bug.