Bug 635779 - Traceback screen doesn't properly display link to bugzilla information
Traceback screen doesn't properly display link to bugzilla information
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: report (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Gavin Romig-Koch
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-09-20 13:12 EDT by James Laska
Modified: 2013-09-02 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: report-0.20-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 05:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot.png (54.94 KB, image/png)
2010-09-20 13:12 EDT, James Laska
no flags Details
Screenshot (Fedora 13).png (43.90 KB, image/png)
2010-09-20 13:18 EDT, James Laska
no flags Details
Screenshot (Fedora 14 Alpha).png (66.94 KB, image/png)
2010-09-20 13:19 EDT, James Laska
no flags Details
fixes this bz by changing the description of the bug to _not_ look like a URL (3.30 KB, patch)
2010-10-11 14:16 EDT, Gavin Romig-Koch
no flags Details | Diff
Screenshot demonstrating behavior using proposed patch (28.88 KB, image/png)
2010-10-11 15:58 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-09-20 13:12:49 EDT
Created attachment 448517 [details]
Screenshot.png

Description of problem:


Version-Release number of selected component (if applicable):
 * anaconda-14.17.3

How reproducible:


Steps to Reproduce:
1. Start the installer
2. Force a traceback (you can boot with updates=http://jlaska.fedorapeople.org/updates/traceback.img)
3. Report the exception report to bugzilla
  
Actual results:

See attached screenshot.  After the issue is reported to bugzilla, a dialog appears.  This dialog doesn't seem to be formatted properly.  It used to display a click-able html *link* to the exception report.  It would only work in the live installer where firefox is available, but still.

Expected results:

A clickable link to the exception report.  I'll attach a screenshot from F13.

Additional info:
Comment 1 James Laska 2010-09-20 13:18:56 EDT
Created attachment 448520 [details]
Screenshot (Fedora 13).png

Exception report dialog in F13 - doesn't have a click-able link, but also doesn't display the link twice
Comment 2 James Laska 2010-09-20 13:19:38 EDT
Created attachment 448522 [details]
Screenshot (Fedora 14 Alpha).png

Exception report dialog in Fedora 14 Alpha - Has a click-able link to the exception report.  This is what I was expecting when testing Fedora 14 Beta
Comment 3 Brian Lane 2010-09-21 12:52:02 EDT
Anaconda uses report to handle this.
Comment 4 Gavin Romig-Koch 2010-09-21 14:43:03 EDT
the report library was recently changed to try to determine if a browser was a callable browser for use by the clickable link before creating it (so that it didn't create clickable links that did nothing).  If there does seem to be a callable browser, it still creates a clickable link.  If there doesn't seem to a callable browser, the report lib just shows the original label and URL that would have made up the clickable link (and admittadly the formatting of this label and URL are not the best).

I didn't think to test the live installer when I implemented this, and so the method I use to determine if there is a usable browser may be faulty in this case.

So for the cases snapshotted above that don't have a clickable link, were these done in live installer, or the normal installer?
Comment 5 James Laska 2010-09-21 15:03:57 EDT
(In reply to comment #4)
> So for the cases snapshotted above that don't have a clickable link, were these
> done in live installer, or the normal installer?

This bug was filed while testing exception reporting in the normal installer.

I just tested the Live installer and it properly shows a clickable link (as one would expect).
Comment 6 James Laska 2010-10-08 16:37:19 EDT
Hey Gavin!  Any updates?  This issue remains with the current installer and not much time remains to include fixes.

Proposing as a nice-to-have fix for F-14.  This issue is clearly not a blocker, but a cosmetic nice-to-have for any users reporting installer crashes through bugzilla.
Comment 7 Gavin Romig-Koch 2010-10-11 14:16:10 EDT
Created attachment 452768 [details]
fixes this bz by changing the description of the bug to _not_ look like a URL

The problem is not that the formatting is off, the problem is that the text in the dialog box that is supposed to be a title or name for the bug is output as a URL.  This proposed patch fixes this bz by changing the 'title/name' text to not be a URL.
Comment 8 Gavin Romig-Koch 2010-10-11 14:20:49 EDT
(In reply to comment #6)
> Hey Gavin!  Any updates?  This issue remains with the current installer and not
> much time remains to include fixes.
> 
> Proposing as a nice-to-have fix for F-14.  This issue is clearly not a blocker,
> but a cosmetic nice-to-have for any users reporting installer crashes through
> bugzilla.

James,
I've posted a proposed patch to this bz.  I didn't think that the fedora-powers-that-be would consider this important enough to break freeze, but you would know better than I.  The patch is very safe, but it just fixes a cosmetic thing.  If you want me to, I'll push this to bodhi and ask for an exception.  Just let me know.
Comment 9 James Laska 2010-10-11 15:27:58 EDT
(In reply to comment #8)
> (In reply to comment #6)
> > Hey Gavin!  Any updates?  This issue remains with the current installer and not
> > much time remains to include fixes.
> > 
> > Proposing as a nice-to-have fix for F-14.  This issue is clearly not a blocker,
> > but a cosmetic nice-to-have for any users reporting installer crashes through
> > bugzilla.
> 
> James,
> I've posted a proposed patch to this bz.  I didn't think that the
> fedora-powers-that-be would consider this important enough to break freeze, but
> you would know better than I.  The patch is very safe, but it just fixes a
> cosmetic thing.  If you want me to, I'll push this to bodhi and ask for an
> exception.  Just let me know.

I'm planning to test the fix now, and pending testing, we can propose this for the nice-to-have list.  This means it would be accepted and pulled into F-14 if the fix was tested and available.  However, the F-14 release wouldn't block on this issue if it weren't tested and available.
Comment 10 James Laska 2010-10-11 15:58:22 EDT
Created attachment 452789 [details]
Screenshot demonstrating behavior using proposed patch

(In reply to comment #9)
> I'm planning to test the fix now, and pending testing, we can propose this for
> the nice-to-have list. 

http://jlaska.fedorapeople.org/updates/635779.img

Using the proposed patch (attachment#452768 [details]), I created an installer updates.img image that 1) contains the patch, 2) another unrelated installer fix, 3) some code to force a traceback at the welcome screen.

Using the provided updates.img, I'm not able to confirm that the proposed fix resolves the issue.  I expected to see a hyper-link (underlined) link to the bug after filing the report.  See attached screenshot.
Comment 11 Gavin Romig-Koch 2010-10-11 17:01:25 EDT
jlaska asked in irc:
<jlaska> prior to F-14, it was a link whether in Live or normal install
<jlaska> if you clicked on the link during a normal install, nothing happened
<jlaska> so the intended change here was to not make that link clickable for the normal installer?
<jlaska> gavin: My expectation was that the behavior observed in F-14-Alpha was the correct intended behavior (see https://bugzilla.redhat.com/attachment.cgi?id=448522)
<jlaska> can you confirm?

prior to F-14, and in F-14 alpha, it was a link whether in Live or normal install.  if you clicked on the link during a normal install, nothing happened.  This behavior was intentionally changed between F14 alpha and F14 beta, such that if there was no browser installed (which is true in the case of the normal installer), then don't display a non-functional hyper link.
Comment 12 James Laska 2010-10-12 11:02:48 EDT
Thanks Gavin, so I understand that this bug involves rewording the F-14-Beta report dialog to not list the URL twice, and to continue with the intended F-14 behavior change noted in comment#11.  I can confirm that the dialog no longer displays the bugzilla bug URL twice using your proposed patch (see attachment#452789 [details]). 

Without this change, the bugzilla report dialog will show the bugURL twice when reporting an exception to bugzilla from a normal (non-live) install?
Comment 13 Gavin Romig-Koch 2010-10-12 11:47:05 EDT
(In reply to comment #12)
 
> Without this change, the bugzilla report dialog will show the bugURL twice when
> reporting an exception to bugzilla from a normal (non-live) install?

Yes.

Would you like me to rebuild (in bodhi) the F14 report with this patch?
Comment 14 James Laska 2010-10-12 12:19:34 EDT
(In reply to comment #13)
> Would you like me to rebuild (in bodhi) the F14 report with this patch?

Please do, thanks!  

This issue will be reviewed at the Friday blocker bug meeting.  Also note, while I think it is a low risk change for the release, and a good fit for the nice-to-have process, there is a possibility it would not qualify as a 'nice-to-have' bug.  As a result, the proposed update would still be tested and available in Fedora 14, but just not included in the official installation media.
Comment 15 Fedora Update System 2010-10-13 15:12:45 EDT
report-0.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/report-0.20-1.fc14
Comment 16 Gavin Romig-Koch 2010-10-13 15:16:23 EDT
I've built and pushed the fix for this into testing (using bodhi). 

Do I need to do anything else for the nice-to-have process?  (I searched for this in Fedoraproject but couldn't find it.)
Comment 17 James Laska 2010-10-13 15:39:20 EDT
(In reply to comment #16)
> I've built and pushed the fix for this into testing (using bodhi). 
> 
> Do I need to do anything else for the nice-to-have process?  

No sir, I believe you are good to go.  This bug has been added to the F14-accepted (aka nice-to-have) Tracking bug.  Release Engineering will use that Tracking bug to pull in any bugs which have tested fixes and are available in bodhi.  

To supply positive bodhi karma, I'll need to figure out how to test the proposed 'report' update.  I gather I can build a live image and test using the bodhi update in updates-testing.  I'll follow-up on that.

> (I searched for
> this in Fedoraproject but couldn't find it.)

The 'nice-to-have' process has just recently been discussed+drafted and you can find it linked off of the QA SOP documents at https://fedoraproject.org/wiki/User:Adamwill/QA:SOP_nth_process_nth_draft

The document will be renamed soon, but will REDIRECT correctly.
Comment 18 Fedora Update System 2010-10-13 17:22:06 EDT
report-0.20-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update report'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/report-0.20-1.fc14
Comment 19 Adam Williamson 2010-10-15 13:49:40 EDT
Discussed at 2010-10-15 review meeting, accepted as NTH.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Fedora Update System 2010-10-19 05:05:30 EDT
report-0.20-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.