Bug 63587 - smp version does not complete boot on S2460 and S2466
Summary: smp version does not complete boot on S2460 and S2466
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-16 00:14 UTC by Seth Bardash
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:39:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Bardash 2002-04-16 00:14:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
RH Linux versions 2.2.14-5.0smp and 2.2.19-6.2.16smp does not finish booting 
after install has completed and boot hangs system on both the Tyan S2460 and 
the Tyan S2466

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 6.2 from CD - Completes install
2.Only runs in uniprocessor mode after this
3.Boot smp kernel hangs at PCI_IDE1: BM-DMA at 0xf007-oxf00f......
It never gets to the line that displays hda:disktype
	

Actual Results:  See steps to reproduce

Single processor version works fine, SMP version hangs on boot
Tried cpu id fix, tried nodma fix, tried updating system and kernel

Expected Results:  It should get through the boot sequence and continue to the 
login prompt.

Additional info:

1) Downloaded kernel 2.2.20 from kernel.org and downloaded updated rpms for 
up2date
2) Ran RH 6.2 2.2.14-5.0 in uniprocessor mode.
3) installed required rpm's to get up2date to work correctly (not trivial)
4) ran up2date to bring whole system to latest rev's including 2.2.19-6.2.16 
kernel and source
5) Still found SMP broken
6) Installed 2.2.20 from item 1 above
7) Built kernel and added it to lilo.conf

8) Booted into 2.2.20 smp kernel with no problems!!!!!

Comment 1 Bugzilla owner 2004-09-30 15:39:30 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.