Bug 63593 - (FPE) 1400x1050 fails with Radeon 7500 QW
(FPE) 1400x1050 fails with Radeon 7500 QW
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
Reported: 2002-04-15 21:51 EDT by John MacLean
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-03 11:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86_log (24.05 KB, text/plain)
2002-04-15 21:52 EDT, John MacLean
no flags Details
XF86Config-4 (2.29 KB, text/plain)
2002-04-21 12:21 EDT, John MacLean
no flags Details
XFree86 error log with 1400x1050 on Psyche (30.17 KB, text/plain)
2002-11-23 13:34 EST, John MacLean
no flags Details

  None (edit)
Description John MacLean 2002-04-15 21:51:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
1400x1050 resolution doesn't work on my Radeon 7500 QW. Hasn't worked since
installing skipjack v1. Tested on skipjack v2, updated XFree86 for skipjack v2,
and Mike's 4.2.0-6.666.

However, it used to work on Enigma using Mike's unofficial 4.1.99 and 4.2.0
packages. I've even tried the XF86Config-4 from this time on XFree86-4.2.0-6.62.

8, 16, 24 bit colour depth doesn't matter.

Only mode presented by Xconfigurator that doesn't work. Unfortunately its my
preferred one.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Put "1400x1050" as first Modes in XF86Config-4 Device section
2.start X

Actual Results:  X doesn't load. See attached /var/log/XFree86.1.log

Additional info:
Comment 1 John MacLean 2002-04-15 21:52:25 EDT
Created attachment 53944 [details]
Comment 2 Bill Nottingham 2002-04-17 00:51:54 EDT
Comment 3 Mike A. Harris 2002-04-19 17:33:18 EDT
1400x1050 is shown as accepted in the log file.  Please attach your config
file.  Not sure what might cause an FPE.  I'll test 1400x1050 on my board.
Comment 4 John MacLean 2002-04-21 12:21:25 EDT
Created attachment 54784 [details]
Comment 5 John MacLean 2002-04-21 12:28:03 EDT
Mike, I've attached the XF86Config-4 generated by the skipjack2 installer and
your 4.2.0-6.666 packages. I manually added the "1400x1050" mode, since neither
Anaconda or Xconfigurator will generate one with this mode enabled (test fails).

Added the config I was using successfully on enigma with your 4.2.0 rpms (sorry,
don't recall exact version - say late Feb/early Mar version).
Comment 6 Mike A. Harris 2002-08-10 14:49:11 EDT
I've reproduced this FPE with a local build, and will try to debug
it and come up with a solution.

Please, in the future do not compress text file attachments.  It makes
it difficult to quickly go to a bug report and click on an attachment
and have it viewable in the web browser.
Comment 7 Mike A. Harris 2002-08-11 23:22:40 EDT
I've reported this upstream for discussion.  Hui Yu from ATI says this
problem is fixed in current XFree86 CVS and has to do with DDA related
code that came over from the r128 driver the radeon driver is based upon.

The problem is claimed to be fixed in XFree86 CVS code currently.

I've made a diff between the two releases in order to try to isolate
the bug fix for this problem.  Unfortunately the diff is 600Kb and
is quite expansive in it's entirety.  I'm not sure what the exact
changes are that fix JUST this bug, and they were checked into
CVS as one big huge monga driver update rather than smaller individual
bugfix updates, so there is no easy way to isolate the fix short of
reimplementing it, and doing some guesswork/troubleshooting.

Since it is claimed as fixed in CVS, I'm going to defer this bug
report for after XFree86 4.3.0 is released, or at least in our
rawhide tree in beta prerelease form.
Comment 8 Mike A. Harris 2002-08-13 08:53:46 EDT
Ok, I just backported the DDA changes from CVS.  I'm not sure if I've
missed anything or not, or if my patch is correct.  I'm building
a new build.  Will you be able to test the new driver right away?

I need testing ASAP in order to try to get this fix into rawhide,
otherwise it might have to wait until the next distro release for
XFree86 4.3.0.

Please let me know ASAP
Comment 9 John MacLean 2002-08-27 19:26:45 EDT
Sorry I've been away on vacation. I've downloaded & tried the 4.2.0-67 packages
but was met with a long list of failed dependencies. If you have something that
will work with an up2date 7.3 install I'll gladly test them.

Nor can I at this time test the latest beta with these packages to see if it
solves the issue. Sorry.
Comment 10 Mike A. Harris 2002-09-01 19:43:43 EDT
I do not have packages for 7.3, sorry.  Unfortunately I don't have
time to test this in depth right now personally.  I'm changing
the bug status to MODIFIED pending testing.  If you test it and
it works please close the bug as RAWHIDE, if it fails, please
reopen as ASSIGNED, and update the report.

Note to jkt/QA - if this report stays in MODIFIED state for too
long, please ASSIGN for testing in a month or so.
Comment 11 John MacLean 2002-11-23 13:32:27 EST
Updated info.
Now running 8.0 w/ XFree86-4.2.0-72
Behaviour is different then previously described. Running X with 1400x1050
resolution results in my monitor (Samsung SyncMaster 900NF) giving a "Sync out
of range - 52.4 KHz 17Hz NN" message. The numbers fluctuate slightly but this is
a typical median.

X does start properly now. ps shows X and the various apps set to autostart as 

I will also give your 4.2.1-9 testing packages a try later this weekend.
Comment 12 John MacLean 2002-11-23 13:34:54 EST
Created attachment 86164 [details]
XFree86 error log with 1400x1050 on Psyche
Comment 13 John MacLean 2002-11-30 15:04:41 EST
I have succeeded in making 1400x1050 work. Googled for some 1400x1050 modeline
info which does work. I consider this bug closed as I no longer get an SIGFPE.

I've opened a bug against redhat-config-xfree86 (#78802).

Comment 14 Mike A. Harris 2003-01-18 06:30:05 EST
If the problem is resolved via a workaround such as a config file
hack, then there must still be an actual bug present which should
be fixed.

Cluttering up our config files isn't the right answer.  I'm reopening
this for further investigation, however I don't know when I'll have
a chance to look into it.  This needs to be tested with our latest
phoebe beta plus latest rawhide code.  I'll do so when I get a chance
though unless you or someone else beats me to it first.  ;o)
Comment 15 John MacLean 2003-01-18 11:21:55 EST
I'm giving the first beta a pass. Most likely will install the next version,
whether it be a second beta or 8.1.
Comment 16 Mike A. Harris 2003-02-03 11:54:05 EST
Radeon 7500 QW works for me in all video modes from 640x480 through
1600x1200 on x86 and x86_64 in 24bit depth.  Never tested other depths.

Closing as fixed in RAWHIDE
Comment 17 Mark J. Cox (Product Security) 2003-06-25 11:52:40 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.