Bug 636027 - RFE: Lifecycle events: Events for storage pools, interfaces, and node devices
Summary: RFE: Lifecycle events: Events for storage pools, interfaces, and node devices
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
: 1343317 (view as bug list)
Depends On:
Blocks: libvirtTodoScale 641273 1447962
TreeView+ depends on / blocked
 
Reported: 2010-09-21 11:19 UTC by Daniel Berrangé
Modified: 2019-02-06 23:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-06 23:46:00 UTC


Attachments (Terms of Use)

Description Daniel Berrangé 2010-09-21 11:19:04 UTC
Description of problem:
To detect the creation & deletion, etc of storage pools, virtual networks, interfaces and node devices, it is necessary to poll on APIs to list them. This is terribly inefficient and contains race conditions. The domain lifecycle event infrastructure should be replicated for all other objects which have a lifecycle process.

Version-Release number of selected component (if applicable):
libvirt-0.8.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Cole Robinson 2014-03-27 12:18:55 UTC
Network events are upstream nowadays, should be easy to extend to storage APIs at least.

Comment 3 Cole Robinson 2016-03-20 23:50:47 UTC
FYI this was proposed as a GSOC 2016 project

Comment 4 Cole Robinson 2016-06-07 14:14:33 UTC
*** Bug 1343317 has been marked as a duplicate of this bug. ***

Comment 5 Cole Robinson 2019-02-06 23:46:00 UTC
Lifecycle events for storage and nodedev objects have been upstream since summer 2016. I doubt interfaces will ever happen, their isn't much modern usage of those APIs.


Note You need to log in before you can comment on or make changes to this bug.