Bug 63610 - Installer shows bug window during package install
Installer shows bug window during package install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 04:18 EDT by Carl Mueller
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Mueller 2002-04-16 04:18:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; H010818)

Description of problem:
I was doing a fresh install on a system with the USB keyboard and mouse plugged 
in through a USB KVM switch.  I got the install going to where it was 
installing packages, then I switched the KVM over to another system to do some 
web browsing.  After 15 minutes or so, I switched back to the installing 
system, and it showed a bug window.  It gave me the option of writing the error 
to a floppy, and here's the contents of that file:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in 
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in 
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or directory: '/mnt/source/RedHat/RPMS/libtiff-
3.5.5-7.i386.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/libtiff-3.5.5-7.i386.rpm
total: 0
self: <todo.ToDo instance at 8444960>
h: <header object at 8b88f30>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 844ed90>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
See description.

Actual Results:  See description.

Expected Results:  See description.

Additional info:

For the install, I selected all packages.  This was the second time I've 
installed off this RedHat CDROM.  The first installation went easily (no bugs), 
and that was to this same system (except with a different hard disk).  This 
second install stopped with the bug window mentioned above.  After saving the 
bug, the system rebooted and I ran the install again (entering identical 
parameters), and this time I did not touch the KVM switch.  This time 
everything worked fine.  I didn't touch the CDROM between these last two 
install attempts.

The system has an Abit BX6r2 motherboard, a GeForce 256 video card, 
Soundblaster Live oem audio card, a 3Com 3c905 NIC, an IDE HD & DVD drive, and 
a Silitek USB keyboard and 3M USB Renaissance mouse.
Comment 1 Michael Fulbright 2002-04-16 16:27:10 EDT
This error is because it could not read a package from the CD. Either the CD is
bad or the CD drive is misbehaving.
Comment 2 Carl Mueller 2002-04-17 02:10:44 EDT
I think you still have work to do.  It's obvious that the CD and drive were 
able to read fine since it worked without problem for two other installations.  
Your installer should not completely bail just because it had difficulty 
reading one file.  First, it should do some retries.  Second, it should allow 
the option of skipping that file if it is not essential.  The idea is that 
software be user friendly.  It shouldn't give a cryptic, non-understandable 
message, and force me to start again from scratch without understanding what is 
going on.
Comment 3 Michael Fulbright 2002-04-24 13:00:49 EDT
I agree that currently it is not easy to follow why this happens.  The kernel
does not give much information about some of the types of read errors that
occur, other than having a system call fail.  In our Skipjack beta which just
came out we have tried to use more of the errors which occur to notify the user.
 I have seen enough bug reports for anaconda to realize that CD hardware is
finicky, and just because it works once doesn't always guarantee it will always
work. If you could md5sum the CD a few times and see if you get the correct
value it would help identify the source of the problem.

Comment 4 Michael Fulbright 2002-05-23 12:53:59 EDT
Closing due to inactivity - please reopen if you have additional comments to add
to this bug.
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.