Bug 636115 - RFE: dnsmasq: rewrite dnsmasq integration to work with a single system instance
RFE: dnsmasq: rewrite dnsmasq integration to work with a single system instance
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks: libvirtTodoNetwork
  Show dependency treegraph
 
Reported: 2010-09-21 10:28 EDT by Daniel Berrange
Modified: 2016-05-02 10:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-02 10:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2010-09-21 10:28:53 EDT
Description of problem:
Upstream dnsmasq offered to extend its functionality to allow libvirt to drop in configuration for a single system instance. This will avoid the problem of clashing dnsmsaq processes on a single host.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 serge 2015-08-27 13:00:21 EDT
Hi,

commit http://libvirt.org/git/?p=libvirt.git;a=commit;h=df3de82c06d42fed832c1955dafdee85879bd15a

changed behavior to always start dnsmasq if ip addresses are defined.  There is no keyword (that I can find) to tell libvirt "don't start a dnsmasq for this bridge, I want to run one myself".  Is adding such a keyword ok, or is it nacked on principle?
Comment 2 Cole Robinson 2016-03-20 19:13:08 EDT
(In reply to serge from comment #1)
> Hi,
> 
> commit
> http://libvirt.org/git/?p=libvirt.git;a=commit;
> h=df3de82c06d42fed832c1955dafdee85879bd15a
> 
> changed behavior to always start dnsmasq if ip addresses are defined.  There
> is no keyword (that I can find) to tell libvirt "don't start a dnsmasq for
> this bridge, I want to run one myself".  Is adding such a keyword ok, or is
> it nacked on principle?

serge if your issue was never resolved I suggest starting a thread on libvir-list instead, it will probably get a better response
Comment 3 Cole Robinson 2016-03-20 19:14:40 EDT
I know we've reworked dnsmasq code quite a bit over the years, but we still haven't gotten around to using a single system dnsmasq instance and I don't really hear people clamoring for it... is this even still relevant?
Comment 4 Cole Robinson 2016-05-02 10:18:08 EDT
Just re-iterating that I don't really see us reworking the network driver to work like this. Maybe we could make it an optional config to use a single system daemon, but since it doesn't sound like there's many requests for this feature and the work isn't exactly forthcoming I don't see the benefit in tracking it here

Note You need to log in before you can comment on or make changes to this bug.