Bug 636141 - DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freedesktop.NetworkManager" isn't exported (or may not exist), can't access property "Devices"
DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freede...
Status: CLOSED DUPLICATE of bug 626780
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:bdc5fa0b3ba640cfe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-21 10:59 EDT by Ben Williams
Modified: 2010-09-21 11:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 11:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (128.72 KB, text/plain)
2010-09-21 10:59 EDT, Ben Williams
no flags Details

  None (edit)
Description Ben Williams 2010-09-21 10:59:21 EDT
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/anaconda/network.py", line 86, in getDefaultHostname
    devices = active_connection_props_iface.Get(isys.NM_MANAGER_IFACE, 'Devices')
  File "/usr/lib/anaconda/iw/network_gui.py", line 37, in getScreen
    self.hostname = network.getDefaultHostname(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1393, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1405, in setScreen
    return self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1314, in nextClicked
    self.setScreen ()
DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freedesktop.NetworkManager" isn't exported (or may not exist), can't access property "Devices"
Comment 1 Ben Williams 2010-09-21 10:59:25 EDT
Created attachment 448715 [details]
Attached traceback automatically from anaconda.
Comment 2 Ben Williams 2010-09-21 11:03:28 EDT
created a respin using pungi
booted to install in vmware workstation and in Virtualbox get this traceback when trying to initialize the hard drive
Comment 3 Colin Walters 2010-09-21 11:18:26 EDT
You need to build a newer anaconda with this pathc:

 http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=60973855b60a187f5461d20f810acb3ce92496c0
Comment 4 Brian Lane 2010-09-21 11:24:02 EDT

*** This bug has been marked as a duplicate of bug 626780 ***

Note You need to log in before you can comment on or make changes to this bug.