Bug 63618 - Please provide full-featured BFD- and opcodes-libs
Please provide full-featured BFD- and opcodes-libs
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: binutils (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 09:03 EDT by Enrico Scholz
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 19:13:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-04-16 09:03:16 EDT
binutils can be configured with '--enable-targets=all' to compile the BFD libs
with support for all targets. Having such libraries is very useful in a cross
compiler environment and "normal" work will not affected by them.

Reversely, it is difficultly to create a consistent cross compiler environment
with the current binutils, because there must be used a library-path which does
not fit into a FHS compliant system.


The only drawback of such libraries is the need for more space (3MB vs. 0.5MB
for libbfd.so and 1.7MB vs. 0.1 MB for libopcodes.so). When this will become a
problem, these libraries can be split into own subpackages (e.g.
binutils-libs-minimal and binutils-libs-maximal).
Comment 1 Jakub Jelinek 2004-10-04 19:13:24 EDT
That's not the only drawback.  E.g. on 32-bit platforms it also
slows down linker/assembler, because bfd_vma etc. are 64-bit and
not 32-bit.
Furthermore, having --enable-targets=all doesn't help you much.
Although you get linker for all targets, you get assembler just
for one (gas is not built for all arches).
So for cross compiles you want binutils configured for the target
in question anyway.

Note You need to log in before you can comment on or make changes to this bug.