Bug 63625 - Process-accounting missing /var/account dir for LSB support
Process-accounting missing /var/account dir for LSB support
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: psacct (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 10:58 EDT by Glen A. Foster
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-16 10:58:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2002-04-16 10:58:04 EDT
Description of Problem: The directory /var/account is missing, according to the
automated/sanctioned LSB tests.  I hope this will be rectified for the upcoming
release that follows the Skipjack (public) beta(s).

Version-Release number of selected component (if applicable):
# rpm -q psacct
psacct-6.3.2-9

How Reproducible: 100%

Steps to Reproduce:
1. Install LSB tests
2. During configuration stage, answer "y" to "Does implementation support
process accounting?" question
3. Run the LSB-FHS tests

Actual Results:
test-case labelled "/LSB.fhs/var/account/account-tc" fails

10|26 /LSB.fhs/var/account/account-tc 16:35:17|TC Start, scenario ref 28-0
15|26 3.3 1|TCM Start
400|26 1 1 16:35:17|IC Start
200|26 1 16:35:17|TP Start
520|26 1 527 1 1|Reference 5.3-1(C)
520|26 1 527 1 2|If the implementation supports process acccounting then
520|26 1 527 1 3|The /var/account directory exists and is searchable
520|26 1 527 1 4|/var/account: directory not found
520|26 1 527 1 5|exit code 1 returned, expected 0
220|26 1 1 16:35:17|FAIL
410|26 1 1 16:35:17|IC End
80|26 0 16:35:18|TC End, scenario ref 28-0

Expected Results: Test should pass

Additional Information: Running latest LSB tests available from opengroup.org
Comment 1 Mike A. Harris 2002-04-16 14:52:09 EDT
Glen!  Howdy!

Yep, the psacct package for 7.[012] is non-FHS compliant.  I fixed it in
rawhide for the upcoming release though to use /var/account.  Also has
an initscript now so people can control it instead of having a force-filled
/var on them.  ;o)

psacct-6.3.2-19 contains the droids you're looking for.  ;o)

/me looks for bugzilla resolution CLOSED->DONUTS and cant see one.. Hmm..

RAWHIDE will have to suffice for now.  ;o)
Comment 2 Glen A. Foster 2002-04-16 15:12:52 EDT
Howdy-hey, Mike.  Thanks for the quick turn-around.  Since DONUTS isn't a 
validated state for defect-resolution, RAWHIDE will have to do, indeed.  Don't 
close it COFFEE_SANDWICH, either; I'll puke! :-)

Note You need to log in before you can comment on or make changes to this bug.