Bug 636326 - After kernel update, screen goes blank during boot
After kernel update, screen goes blank during boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 630811 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker 637926
  Show dependency treegraph
 
Reported: 2010-09-21 18:23 EDT by W. Michael Petullo
Modified: 2010-10-11 16:45 EDT (History)
13 users (show)

See Also:
Fixed In Version: kernel-2.6.35.5-30.fc14.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-10 20:11:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from last properly-working kernel (2.6.35.4-25.fc14.x86_64) (52.69 KB, text/plain)
2010-09-22 07:24 EDT, Steven Usdansky
no flags Details

  None (edit)
Description W. Michael Petullo 2010-09-21 18:23:12 EDT
Description of problem:
I recently updated my kernel from kernel-2.6.35.4-12.fc14.x86_64 to kernel-2.6.35.4-28.fc14.x86_64. No other packages were updated at the time. The update resulted in the system's screen going black during boot. Adding "nomodeset" to the kernel's boot arguments fixed the problem, but resulting in sub-optimal video.

Version-Release number of selected component (if applicable):
kernel-2.6.35.4-28.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade to  kernel-2.6.35.4-28.fc14.x86_64 and reboot.

Additional info:
The system is a MacBook 5,1 and uses the nouveau driver. Lspci reports, "02:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce 9400M] (rev b1)."
Comment 1 Steven Usdansky 2010-09-21 21:04:34 EDT
Same problem with both kernel-2.6.35.4-28.fc14.x86_64 and kernel-2.6.35.5-29.fc14.x86_64. kernel-2.6.35.4-12.fc14.x86_64 is good.

~# lspci | grep VGA
02:00.0 VGA compatible controller: nVidia Corporation C78 [GeForce 9100] (rev a2)

Can boot with nomodeset parameter on the kernel line, but then can't use X with nouveau driver.
Comment 2 Steven Usdansky 2010-09-22 07:24:44 EDT
Created attachment 448912 [details]
dmesg from last properly-working  kernel (2.6.35.4-25.fc14.x86_64)

kernel-2.6.35.4-25.fc14.x86_64 boots properly.
kernel-2.6.35.4-26.fc14.x86_64 does not boot properly.

First entry in changelog for kernel-2.6.35.4-26.fc14.x86_64:
* Mon Sep 13 2010 Ben Skeggs <bskeggs@redhat.com> 2.6.35.4-27 - nouveau: fix oops in acpi edid support
Comment 3 Steven Usdansky 2010-09-22 14:06:38 EDT
Can't duplicate the good result I had earlier with kernel-2.6.35.4-25.fc14.x86_64 I just rebooted my desktop PC after having shut it off for several hours. However, kernel-2.6.35.4-12.fc14.x86_64 still works for me
Comment 4 Ben Skeggs 2010-09-22 20:27:52 EDT
Can you retry with: http://koji.fedoraproject.org/koji/taskinfo?taskID=2482757
Comment 5 Steven Usdansky 2010-09-23 08:25:32 EDT
Shut the desktop down for about 10 min, then rebooted using kernel-2.6.35.5-30.fc14.x86_64. Posting from that now, so I'd say it seems to work. Will report back if I encounter any problems after a longer shutdown
Comment 6 Steven Usdansky 2010-09-23 19:26:29 EDT
Everything seems to work properly after long (1 hr+) shutdowns. Problem appears to be fixed.
Comment 7 Ben Skeggs 2010-09-23 20:04:14 EDT
Thanks for letting us know :)
Comment 8 Ben Skeggs 2010-09-25 21:39:39 EDT
*** Bug 630811 has been marked as a duplicate of this bug. ***
Comment 9 W. Michael Petullo 2010-10-04 19:57:53 EDT
Seems fixed after I upgraded to kernel-2.6.36-0.32.rc6.git2.fc15.x86_64. I have been waiting for the next Fedora 14 kernel and will test it once it is available.
Comment 10 Adam Williamson 2010-10-08 11:47:09 EDT
Michael, did you test the kernel Ben linked to above?

proposing as F14Blocker to make sure this fix doesn't slip through the cracks.
Comment 11 James Laska 2010-10-08 12:30:53 EDT
If it helps, I was seeing this also with the reported kernel on my macbook

02:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce 9400M] (rev b1)

Using 2.6.35.5-30.fc14.x86_64, I no longer see the issue.
Comment 12 Adam Williamson 2010-10-08 12:35:05 EDT
This was discussed and accepted as a blocker at the 2010-10-08 review meeting.

Ben / kernel team, it would be great if you could push all the stuff you want in F14 and come up with a proposed final kernel by Monday; that way we can have it in TC1 for testing.
Comment 13 W. Michael Petullo 2010-10-10 19:18:21 EDT
kernel-2.6.35.5-30.fc14.x86_64 solves this issue for me.
Comment 14 Adam Williamson 2010-10-10 20:11:59 EDT
-39 has been pushed stable, so let's close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 W. Michael Petullo 2010-10-11 16:45:58 EDT
Confirmed fixed in 2.6.35.6-39.fc14.x86_64.

Note You need to log in before you can comment on or make changes to this bug.