Bug 636382 - pm-utils contains non-upstream hook specifically calling hal
Summary: pm-utils contains non-upstream hook specifically calling hal
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-22 03:14 UTC by abrouwers
Modified: 2010-10-28 06:05 UTC (History)
5 users (show)

Fixed In Version: pm-utils-1.3.1-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 06:05:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (663 bytes, patch)
2010-10-11 15:13 UTC, Jaroslav Škarvada
no flags Details | Diff

Description abrouwers 2010-09-22 03:14:11 UTC
Description of problem:

Recently, pm-utils 1.3.x in F14 removed the dependency on hal; however, one of the hooks still seems to call it specifically:

[root@thinkpad andrew]# cat /usr/lib64/pm-utils/sleep.d/99hd-apm-restore.hook | grep hal
for udi in $(hal-find-by-capability --capability storage)
    drive_type=$(hal-get-property --udi "${udi}" --key storage.drive_type)
        HD_APM_DEVICES+="$(hal-get-property --udi "${udi}" --key block.device | sed 's,^/dev/,,') "

[root@thinkpad andrew]# rpm -qR pm-utils
/bin/bash  
/bin/sh  
config(pm-utils) = 1.3.1-1.fc14
hdparm  
kbd  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
radeontool  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
vbetool  
rpmlib(PayloadIsXz) <= 5.2-1 

On my gnome install, since nothing else depends on hal, I have removed the it from the system, but now receive an error when that hook is called:

/usr/lib64/pm-utils/sleep.d/99hd-apm-restore.hook resume suspend:/usr/lib64/pm-utils/sleep.d/99hd-apm-restore.hook: line 38: hal-find-by-capability: command not found
success.

Perhaps this RH-specific hook should be removed from the new pm-utils packages ?


Version-Release number of selected component (if applicable):

pm-utils-1.3.1-1.fc14.x86_64
No hal install on the system


Steps to Reproduce:
- Install pm-utils
- Remove hal goodies
- Suspend laptop
- View /var/log/pm-suspend.log

Comment 1 Richard Hughes 2010-09-22 10:00:27 UTC
I think we can dump 99hd-apm-restore.hook for good.

Comment 2 Jaroslav Škarvada 2010-10-11 15:13:53 UTC
Created attachment 452733 [details]
Proposed patch

I think it can be useful, the proposed "de-hal-ization" patch is included. Any other reason for dropping?

Comment 3 Richard Hughes 2010-10-12 07:43:47 UTC
Jaroslav, well, it either needs to be pushed upstream, or be dropped. There's no need for such a Fedora specific patch.

Comment 4 Jaroslav Škarvada 2010-10-12 09:10:35 UTC
This originates from bug 382061 as HD PM restore is not handled by kernel. It seems to be handled (another way) by harddrive script in pm-utils-1.4.1, but not in previous versions of pm-utils. I am going to drop it with 1.4.1 but I consider it to be useful with lower versions of pm-utils.

Comment 5 Fedora Update System 2010-10-13 13:01:47 UTC
pm-utils-1.3.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pm-utils-1.3.1-3.fc14

Comment 6 Fedora Update System 2010-10-13 21:21:01 UTC
pm-utils-1.3.1-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pm-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pm-utils-1.3.1-3.fc14

Comment 7 Fedora Update System 2010-10-28 06:05:04 UTC
pm-utils-1.3.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.