This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 63642 - Broadcasts from 0.0.0.0 on network restart
Broadcasts from 0.0.0.0 on network restart
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: iproute (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 13:45 EDT by Jason Tibbitts
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 07:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2002-04-16 13:45:24 EDT
Description of Problem:
At bootup or when the network service is restarted, a Red Hat 7.2 machine will
send two odd ARP broadcasts:

#tcpdump -n host 0.0.0.0
12:37:59.471033 eth0 B arp who-has 129.7.128.137 (Broadcast) tell 0.0.0.0
12:38:00.461030 eth0 B arp who-has 129.7.128.137 (Broadcast) tell 0.0.0.0

These are not DHCP traffic; the machine has a fixed IP address (129.7.128.137)
and obviously knows it at this point. 

Version-Release number of selected component (if applicable):
Red Hat Linux 7.2 with updates, iputils 20001110-6, initscripts 6.43-1

Normally I wouldn't care about two packets, but besides the fact that they're
unnecessary, I also run arpwatch and am now (after rolling out RH 7.2) being
constantly bugged about 0.0.0.0 changing its hardware address.  Red Hat 7.1 and
earlier did not do this.  The current betas also have this issue.

How Reproducible:
trivially reproduced

Steps to Reproduce:
1. run tcpdump host 0.0.0.0 somewhere else on the local network
2. service network restart
Comment 1 Jason Tibbitts 2002-04-16 14:43:11 EDT
It has been suggested that these are an attempt to detect whether the IP address
is already in use and to avoid bringing up the interface if so.  I can't find
this documented anywhere, but if it is intended, then I'll file a bug against
arpwatch for bugging me when this happens.
Comment 2 Phil Knirsch 2002-04-17 07:01:43 EDT
I'll check maybe with our kernel folks as well if this is intentional.
If so, reasigning this bug to arpwatch is probably a good idea.

Read ya, Phil
Comment 3 Jason Tibbitts 2002-04-17 10:03:59 EDT
OK, I found that this comes from the following lines in /sbin/ifup:

if ! arping -q -c 2 -w 3 -D -I ${DEVICE} ${IPADDR} ; then
    echo $"Error, some other host already uses address ${IPADDR}."
    exit 1
fi

Also, upgrading arpwatch to 2.1a11-10.7x stopped the annoying notices.  (I was
at 2.1a4-29 from 7.0.)

So if bugzilla will let me, I'll resolve this myself.  I apologize for wasting
your time.

Note You need to log in before you can comment on or make changes to this bug.