Bug 636491 - scanner not recognized under F14 Beta RC3 liveCD gnome desktop
Summary: scanner not recognized under F14 Beta RC3 liveCD gnome desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: simple-scan
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-22 11:11 UTC by malak
Modified: 2011-03-21 20:58 UTC (History)
2 users (show)

Fixed In Version: simple-scan-2.32.0.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-21 20:58:04 UTC


Attachments (Terms of Use)

Description malak 2010-09-22 11:11:09 UTC
Description of problem:

When simple-scan is activated, it does not identify my HP Deskjet F4180, despite the necessary driver(s) and dependencies having just been installed

Version-Release number of selected component (if applicable):

F14 Beta RC3 liveCD gnome desktop

How reproducible:

reasonably so?

Steps to Reproduce:
1. connect and turn on HP Deskjet F4180
2. allow system to install requisite
3. under gnome desktop, launch simple-scan
  
Actual results:

simple-scan gave an error message indicating that no scanner was found, or that perhaps it wasn't turned on.

Expected results:

The scanner should have been identified and simple-scan should have worked so that I could do a simple test scan

Additional info:

A suggestion on "Discussions about development for the Fedora desktop <desktop@lists.fedoraproject.org>" was to install the package libsane-hpaio

Comment 1 malak 2010-09-22 11:13:51 UTC
In "steps to reproduce" #2 should read "allow system to install requisite drivers and dependencies"

Comment 2 Adam Williamson 2010-09-22 12:56:07 UTC
Did you try installing libsane-hpaio yet? Did that solve the problem?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 malak 2010-09-22 21:08:46 UTC
Hi Adam

YES I just installed libsane-hpaio.

NO it did NOT solve the problem.

Comment 4 malak 2010-09-22 21:47:18 UTC
For what it's worth, I just installed xSane, and it doesn't detect any scanners either.

I did the following:

yum install xsane (successful)

xsane didn't detect any scanner, so I did the following two installs:

yum install sane (successful)
yum install sane* (successful)

after each installation xsane still said that it didn't detect any devices.  Just to satisty myself I tried simple-scan too, and in each case it didn't detect any devices either.

Here's a resource page on the subject, dated from January 2010:

http://linux.derkeiler.com/Mailing-Lists/Fedora/2010-01/msg01648.html

In any case, I've had no difficulties at all with the scanner on my full install of Fedora 12 since the beginning.

I'm going to play with a couple of other options to see what's happening.

Comment 5 malak 2010-09-22 22:49:05 UTC
I just repeated the above process with the F9 liveCD, and the result was the same.  According to my standard installation notes, For F12 all I did was install xSane, and I have always been able to use the scanner.

Comment 6 malak 2010-09-24 02:23:38 UTC
I just installed Fedora 14 Beta rc3 gnome desktop on another machine from the DVD.  I plugged in the same printer to the machine.  The new machine recognized the printer, found the appropriate drivers, and installed them.

I launched simple-scan from the "Applications/Graphics" menu.  It immediately recognized the scanner and immediately performed a test scan at my request.

Comment 7 Fedora Update System 2011-03-01 07:17:48 UTC
Package simple-scan-2.32.0.1-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing simple-scan-2.32.0.1-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/simple-scan-2.32.0.1-1.fc14
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-03-02 01:53:59 UTC
simple-scan-2.32.0.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update simple-scan'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/simple-scan-2.32.0.1-1.fc14

Comment 9 Fedora Update System 2011-03-21 20:57:36 UTC
simple-scan-2.32.0.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.