Bug 63655 - PCMCIA network interface handled incorrectly on laptop resume
Summary: PCMCIA network interface handled incorrectly on laptop resume
Status: CLOSED DUPLICATE of bug 62288
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-16 23:02 UTC by keithu@parl.clemson.edu
Modified: 2014-03-17 02:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description keithu@parl.clemson.edu 2002-04-16 23:02:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The PCMCIA network interface cards I have (one wired, one wireless) are handled
incorrectly after a laptop resume.  Even if the interfaces are configured to not
come up on boot and even if I ifdown both interfaces before suspend, both
interfaces come back up on resume.  This does not happen with the internal
interface.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.acquire laptop
2.acquire PCMCIA network interface
3.configure pcmcia network interface to not configure on boot
4.ifdown the interface
5.suspend laptop
6.resume laptop
	

Actual Results:  The PCMCIA network interface was activated.

Expected Results:  The PCMCIA network interface should not have been activated.

Additional info:

For most users, this will be a relatively minor problem.  For me, I have a
laptop w/ a winmodem, so I bought a nice, trustworthy 3COM combo card (had used
it before and trusted it).  Well, I will have two  
PCMCIA network interfaces most of the time - the 3COM one and a wireless card. 
Most of the time, only one should be up.  having both come up after a suspend is
annoying.

Comment 1 Bill Nottingham 2002-04-17 04:43:27 UTC
Hm, is this hotplug bringing up the interfaces?

Comment 2 keithu@parl.clemson.edu 2002-04-19 03:28:13 UTC
Just realized that the same happens with the built-in network interface.  It had
not been coming up before because another card was interfering (long story). 
Anyway, the short version is that the built-in (non-PCMCIA) network interface
also comes up after suspend whether it was up before the suspend or not.

Comment 3 Bill Nottingham 2003-02-21 01:12:07 UTC
Does 

*** This bug has been marked as a duplicate of 62288 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:48:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.