Bug 63657 - klipper doesn't launch mozilla properly
klipper doesn't launch mozilla properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-16 19:34 EDT by Joshua Jensen
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 09:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-04-16 19:34:30 EDT
Description of Problem:

On a konsole or xterm, when highlighting "www.redhat.com", klipper's pop-up
dialog doesn't launch mozilla if it isn't already started.  I works perfectly if
mozilla is already up... but otherwise it will not bring up a mozilla window on
it's own.

Version-Release number of selected component (if applicable):

[joshua@mule joshua]$ rpm -qf `which konqueror`
kdebase-3.0.0-9
Comment 1 Bernhard Rosenkraenzer 2002-04-17 07:27:04 EDT
Klipper launches  
  
mozilla -remote "openURL(whatever, new-window)"  
  
Looks like mozilla doesn't start a session if none is running. 
Changing it to launching just 
 
mozilla whatever 
Comment 2 Joshua Jensen 2002-04-17 09:09:07 EDT
From a command prompt I see:

[joshua@mule joshua]$ mozilla -remote "openURL(http://www.redhat.com, new-window)"
No running window found.

Cross-filing a bug with mozilla:  bugzilla number 63681.
Comment 3 Bernhard Rosenkraenzer 2002-04-17 10:39:44 EDT
3.0.0-11 launches the following: 
ps x |grep -q '[m]ozilla' && mozilla -remote "openURL(%s, new-window)" || 
mozilla "%s"

Note You need to log in before you can comment on or make changes to this bug.