Bug 636708 - Dashboard - Favorite resources: No scrollbar when there are several resources
Dashboard - Favorite resources: No scrollbar when there are several resources
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
Corey Welton
:
Depends On:
Blocks: rhq4 jon30-dashboard
  Show dependency treegraph
 
Reported: 2010-09-22 21:14 EDT by Corey Welton
Modified: 2011-05-23 21:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-09-22 21:14:53 EDT
Description of problem:

If user has 'favorited' a bunch of resources, a number that would take up more than the available space inside the Favorite resources portlet - it is not readily apparent that all of them are listed in the portlet, since there is no scrollbar.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Add a bunch of resources (probably 5+) to your favorites
2.  Go back to dashboard; add the favorite resources portlet if it is not there already
3.  View results.
  
Actual results:
* Portlets scroll somewhat unnoticed off the bottom of the portlet.  The portlet can scroll (say, with a mousewheel) but there is no evident scrollbar.

Expected results:
Scrollbar when appropriate

Additional info:

There's actually a whole lot of whitespace around each of these that can probably be reduced, but the scrollbar should be there regardless
Comment 1 Corey Welton 2010-09-22 22:49:58 EDT
This appears to only be the case in the smaller left-hand column, at least in the initial two-column view.  It may occur elsewhere in scenarios where you have a bunch of small columns.
Comment 2 John Mazzitelli 2011-03-24 10:00:29 EDT
simeon is working on the portlets. this issue may already be fixed, will let him close this if appropriate.
Comment 3 Jay Shaughnessy 2011-03-31 17:15:36 EDT
This looks to be resolved.
Comment 4 Mike Foley 2011-04-14 08:05:45 EDT
verified through interactive testing.  vertical scrollbar exists on favorites portlet when there are > 5 favorites.
Comment 5 Corey Welton 2011-05-23 21:16:11 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:16:24 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:16:25 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 8 Corey Welton 2011-05-23 21:16:29 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.