Bug 636723 - Dashboard: Refresh button appears to be non-functioning for Summary Count, Platforms Summary Portlets
Dashboard: Refresh button appears to be non-functioning for Summary Count, Pl...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
Corey Welton
:
Depends On:
Blocks: rhq4 jon30-dashboard
  Show dependency treegraph
 
Reported: 2010-09-22 23:03 EDT by Corey Welton
Modified: 2011-05-23 21:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-09-22 23:03:25 EDT
Description of problem:
Clicking the "refresh" button on the Summary Count and Platforms Summary portlets does not appear to do anything; I am not sure it even activates, or if it is hooked up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Add Platforms Summary and Summary Count portlets to a dashboard.
2.  Click the refresh button
3.  View results
  
Actual results:
This button does nothing on these two portlets.  It doesn't even appear to be trying to hit the server.

Expected results:
Either hook these up, or remove refresh button from portlet(s) that don't support refresh.

Additional info:
Comment 1 Simeon Pinder 2010-09-24 10:32:30 EDT
I pushed fix for this last night. Should work successfully with master builds >= 341. 
commit hash: e84012cf010751c9eb71439d954f56170c060306
Comment 2 Corey Welton 2010-09-29 14:38:51 EDT
This seems to be working for Summary Count, but I'm not sure Platforms Summary refresh is working.  Clicking the button doesn't cause any noticeable refresh, and I am not seeing anything take place in the server logs.  Returning to dev for consideration.
Comment 3 Simeon Pinder 2011-04-04 17:02:41 EDT
Yep. I missed the Platform Summary portlet as it's not one of the default visible portlets. This has been fixed with commit: 4029f205610b44761109cf4e9d19574dc5df3265

Putting to ON_QA.
Comment 4 Mike Foley 2011-04-18 20:14:17 EDT
Platform Utilization report ... when refreshed ... does indeed get new information from the RHQ server ... as evidenced by Chrome developer tools which trace the lower level calls and responses.  Verified.
Comment 5 Corey Welton 2011-05-23 21:11:39 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:11:40 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.