This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 636725 - Dashboard - Discovery Queue: Ignore/Unignore buttons seem conceptually incorrect/non-intuitive
Dashboard - Discovery Queue: Ignore/Unignore buttons seem conceptually incorr...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: rhq4 jon30-dashboard
  Show dependency treegraph
 
Reported: 2010-09-22 23:28 EDT by Corey Welton
Modified: 2011-05-23 21:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-09-22 23:28:31 EDT
Description of problem:
* Once something is "Ignored" in the discovery queue, there doesn't seem to be a way to bring it back
* User can "unignore" resources that have been neither added nor ignored in the resource queue; this doesn't seem to make sense. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Add discovery queue portlet to your dashboard
2.  Register a new agent to your server; wait for the autodiscovery queue portlet to populate
3.  Expand the resource tree for the newly discovered agent 
4. Selectively Import some, but not all of the resources.  Leave at least two unimported.
5. For one of the remaining resources, click the Ignore button.
6. For any of the remaining resources, click the Unignore button
  
Actual results:
* Ignoring a resource causes it to go away - I see no way to bring it back
* "Unignoring" a resource that is still in the tree does nothing. 

Expected results:
* Should be a way to bring back a resource that has been ignored -- probably using the unignore function in some manner.
* The unignore button seems to serve no contextual purpose for resources that are neither inventoried nor ignored.

There should probably be some tabbed view, with all ignored resources listed there, or they should be in the tree but grayed out or something.  The current structure is bewildering.

Additional info:
Comment 1 John Mazzitelli 2011-02-15 10:56:36 EST
commit 3e11593249769dda043a4332a44c9450ce0de708

the problem is the main Inventory>AutoDiscovery view had the drop down that let you view the ignored resources, but the portlet was missing that feature, thus it was confusing.

Now the portlet and main views both have the same "Show" drop down within the footer that allows you to show the ignored resources, thus making the "unignore" button meaningful and useful.
Comment 2 Mike Foley 2011-04-13 08:42:47 EDT
this is verified through interactive testing by following the reproduction steps.  imported some resources, ignored some resources, and was later able to view and import ignored resources.
Comment 3 Corey Welton 2011-05-23 21:14:03 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:14:04 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:14:07 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.