Bug 636749 - System lies about going to reboot
System lies about going to reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-09-23 03:15 EDT by Nicolas Mailhot
Modified: 2010-11-21 16:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-21 16:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-09-23 03:15:40 EDT
Description of problem:

The system claims it is going to reboot, but aborts silently, without notifying the admin

# /sbin/init 6
Failed to issue method call: Transaction order is cyclic. See system logs for details.

Broadcast message from nim@arekh.okg on pts/0 (Thu, 23 Sep 2010 09:11:57 +0200):

The system is going down for reboot NOW! (yes sure)


Version-Release number of selected component (if applicable):
systemd-units-10-1.fc14.x86_64
systemd-gtk-10-1.fc14.x86_64
systemd-sysvinit-10-1.fc14.x86_64
systemd-10-1.fc14.x86_64
Comment 1 Michal Schmidt 2010-09-23 03:50:14 EDT
The ordering cycle is the one you described in bug 635066?
Comment 2 Nicolas Mailhot 2010-09-23 03:58:35 EDT
Yes

This bug is about the system claiming it is rebooting, even though it isn't
(there is a similar bug for init 1)
Comment 3 Matthias Clasen 2010-10-08 18:46:25 EDT
Moving systemd bugs to f15, since the systemd feature got delayed.
Comment 4 Lennart Poettering 2010-11-21 16:25:21 EST
This has been fixed in v13. Cyclic deps do not cause boot to fail anymore, and neither do any services/mounts that fail to shut down.

Note You need to log in before you can comment on or make changes to this bug.