This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 63680 - ntp enable checkbox DOA
ntp enable checkbox DOA
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dateconfig (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-17 08:44 EDT by Bryce Nesbitt
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 17:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ntp.conf file, as managed by dateconfig (1.74 KB, text/plain)
2002-05-23 10:08 EDT, Bryce Nesbitt
no flags Details

  None (edit)
Description Bryce Nesbitt 2002-04-17 08:44:45 EDT
Oh great, I thought, a checkbox to enable ntp!  This
will make it easy.

The dateconfig checkbox does not seem to work.  I get no feedback about any
problem, but the system log shows:


Apr 17 08:42:01 hardhat ntpd[3074]: ntpd 4.1.0 Wed Sep  5 06:54:30 EDT 2001 (1)
Apr 17 08:42:01 hardhat ntpd: ntpd startup succeeded
Apr 17 08:42:01 hardhat ntpd[3074]: precision = 18 usec
Apr 17 08:42:01 hardhat ntpd[3074]: kernel time discipline status 0040
Apr 17 08:42:01 hardhat ntpd[3074]: getnetnum: "terrapin.csc.ncsu.edu" invalid
host number, line ignored
Apr 17 08:42:01 hardhat ntpd[3074]: Un-parsable frequency in /etc/ntp/drift
Apr 17 08:42:01 hardhat ntpd[3074]: bind() fd 9, family 2, port 123, addr
224.0.1.1, in_classd=1 flags=0 fails: Address already in use
Apr 17 08:42:01 hardhat ntpd[3074]: ...multicast address 224.0.1.1 using
wildcard socket


I've tried all 4 timeservers in dateconfig, and tried disabling the firewqall. 
The RedHat default firewall is definitely a problem, but not the only problem.
Comment 1 Brent Fox 2002-04-17 10:28:06 EDT
Can you attach your /etc/ntp.conf file?  Looks like the file may have gotten
messed up.
Comment 2 Brent Fox 2002-05-22 23:38:11 EDT
Closing due to lack of information.
Comment 3 Bryce Nesbitt 2002-05-23 10:08:16 EDT
Created attachment 58284 [details]
ntp.conf file, as managed by dateconfig
Comment 4 Bryce Nesbitt 2002-05-23 10:10:33 EDT
I eventually gave up dateconfig in frustration, and added this to rc.local:
       echo -n "Synchronizing with time server ntp.cmr.gov... "
       /usr/sbin/ntpdate -s -b ntp.cmr.gov
This demonstrates the problem is not with ntp.cmr.gov.
Comment 5 Brent Fox 2002-05-23 10:29:45 EDT
Strange, I can connect to the four default servers, the internal Red Hat time
server, and also ntp.cmr.gov.  I don't know what the problem is.

You might try upgrading to the dateconfig from 7.3, but I don't know if that
will make a difference or not.
Comment 6 Bryce Nesbitt 2002-05-23 12:40:49 EDT
It's not a problem with dateconfig, it's a problem with ntpd as shipped by RedHat.

Dateconfig fails to notice the lack of a firewall hole AND some other mystery
condition preventing ntp from actually functioning.  Dateconfig should be making
sure that ntpd can work, and checking that it started up OK (offering a
non-functional checkbox to the user is bad).
Comment 7 Brent Fox 2002-05-23 12:52:22 EDT
Ok, I will try to notify the user if starting ntp fails for some reason. 
Detecting the lack of a firewall hole is hard, though.  This isn't just a
problem with dateconfig either, it affects pretty much every other network
service config tool in the distro.  We don't have a consistent way of seeing
whether the service we are configuring can actually get out to the outside
world.  I don't see us having a solution for that anytime soon, though.
Comment 8 Bryce Nesbitt 2002-05-23 16:24:29 EDT
I'm still at a loss for WHY ntp fails to start up.
It's dateconfig's job to warn that ntp is not working.
It's ntp's job to work :-).
Comment 9 Brent Fox 2002-05-23 17:40:34 EDT
I'm going to cc: harald on this report since he is our ntp maintainer.  Maybe he
can tell what is going on with ntp.
Comment 10 Brent Fox 2002-07-10 15:45:29 EDT
Ok, I've changed dateconfig to notify the user if the ntp server can't be
contacted.  Please open a new bug against ntp if there's still a problem. 
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.