Bug 63688 - up2date crashes with error code 9 when started
up2date crashes with error code 9 when started
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-17 10:33 EDT by Les Dabney
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-18 18:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Les Dabney 2002-04-17 10:33:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; Q312461)

Description of problem:
Error Class Code: 9
Error Class Info:Invalid Server Certificate

This is the only thing that happens when I try to run this program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply trying to run the program gets the error.
2.
3.
	

Additional info:
Comment 1 Adrian Likins 2002-04-17 15:05:29 EDT
That error indicates that the systemid you have in /etc/sysconfig/rhn/systemid
is not valid for the server you are talking to. 

I havent seen this in a long time (not since we still ran a beta rhn server
almost 8 months ago....), as register to one server (say, beta.rhns..)
and then having up2date talk to another server (say, www.rhns.redhat.com) can
cause this.

Best approach is to verify that both rhn_register and up2date are configure
to talk to the right server (both should be configured to talk to
https://www.rhns.redhat.com/XMLRPC ). And then reregister the system.
Comment 2 David M. Cook 2002-04-18 18:49:50 EDT
First make sure that the machine is pointing to the right server,
www.rhns.redhat.com.  Run

up2date --configure --nox

and check that noSSLServerURL and serverURL look like the following:

serverURL: https://www.rhns.redhat.com/XMLRPC
noSSLserverURL: http://www.rhns.redhat.com/XMLRPC

If that's OK, you'll need to re-register the box if you haven't already, and
then move
your entitlement to the new profile.

Run 

rhn_register 

as root.  Click "Yes" if you get the dialog message about the system already
being registered.

Once the system is registered, log in at http://rhn.redhat.com , click on
"Entitlements" on the left, and then move the entitlement from the old
system to the new system.  Then click on "Update Entitlements" at the bottom.

To delete the old profile altogether from the Entitlements page, click on
the name of the system in the Entitled systems list. At the bottom of the
page, below the details information, is the Delete System Profile button.
Clicking that will prompt for confirmation that you really want to delete
the profile then remove it from your account.


Note You need to log in before you can comment on or make changes to this bug.