Bug 63715 - [RFE] Filter for RHN_Register or UP2DATE -p
[RFE] Filter for RHN_Register or UP2DATE -p
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-17 16:12 EDT by Need Real Name
Modified: 2015-01-07 18:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 19:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-17 16:12:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; Pajo 
Networks; .NET CLR 1.0.3705)

Description of problem:
The one component that is missing in my opinion with both the RHN_REGISTER and 
UP2DATE -p component of the update agent system is the ability to limit what 
we send you when we register packages with your servers. What I am asking for 
is a filter to "block" your servers from learning about packages I have 
installed. This list can be derived either by "file" name or an attribue 
inside of the RPM package itself.

This comes from the fact that on our servers (and workstations) there are 
times we install a large group of files that we dont need REDHAT knowing 
about. If we decinded in the furtue to show you then fine. A good example is a 
workstation running Ximian Gnome. They [ximian] replace a massive amount of 
files for Gnome from GTK to Gnome-Libs, they prefix the FILENAME with *-
ximian.rpm. So it would be nice to set up a filter that states something like: 
up2date -p --ignorefilename *-ximian.rpm.  This would allow us to update with 
RedCarpet (ximain gnome updater) and RHN for Redhat specific. Furthermore, we 
have many "3rd" party software apps that we dont need you to know about. It 
keeps the list of erratas and updates > 0 on your RHN site.

If there is a way now, please let me know.

Thanks,
Alex Paoli (alex.paoli@pajo.com)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.It is a WISH
2.
3.
	

Additional info:
Comment 1 Adrian Likins 2002-04-17 16:28:05 EDT
The rhn_regsiter client allows you to select which packages you
want to send info about (there is a checklist, you can uncheck
any packages that you dont want us to know about).

However, not sending the info to the server prevents
us from being able to do proactive notification of updates.

Also, that only changes what info we store. So I
dont think this will solve the ximian-on-redhat 
dep solving issues. Basically, the ximian packages
arent compatiable with ours, and that breaks dep
solving in big ways. Especically in cases where
our updates involves updating soemthing that is
also provided by ximian, which is fairly common.

I'm not sure if I understand how 3rd party apps
would cause the errata list to be greater than 0. 
Since we dont have updates for the 3rd party
apps, they should ever cause an errata to be
flagged as needed. 
Comment 2 David M. Cook 2002-04-17 19:31:04 EDT
It would be useful to be able to match skip patterns on version or release
"numbers".  Then skipping things with "*ximian*" in the release number would work.
Comment 3 Josef Komenda 2002-11-12 12:41:39 EST
Current solution is to buy a proxy or satellite. Closing.

Note You need to log in before you can comment on or make changes to this bug.