This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 637308 - [RFE] widen the blkfront ring buffers to more than one page
[RFE] widen the blkfront ring buffers to more than one page
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Red Hat Kernel QE team
: EC2, FutureFeature
Depends On: 656362
Blocks: 523117
  Show dependency treegraph
 
Reported: 2010-09-24 17:07 EDT by Jay Greguske
Modified: 2011-09-06 08:58 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 656362 (view as bug list)
Environment:
Last Closed: 2011-09-06 08:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Amazon-provided kernel patch (9.17 KB, patch)
2010-09-24 17:07 EDT, Jay Greguske
no flags Details | Diff

  None (edit)
Description Jay Greguske 2010-09-24 17:07:47 EDT
Created attachment 449523 [details]
Amazon-provided kernel patch

Amazon proposed a patch to get better performance out of EBS-backed AMIs. It is based on 2.6.35, and well tested according to them.

I've attached it here for review & consideration.
Comment 4 Andrew Jones 2010-11-23 09:16:19 EST
I see what they're doing, and looks ok, but we should really push stuff like this upstream first. Is Amazon planning on posting this patch to xen-devel and lkml? Or should we take it through the phases?
Comment 5 Paolo Bonzini 2010-11-23 10:36:50 EST
The backend part is missing.  Maybe this is a private Amazon patch?  We would need to include that in our RHEL5 kernel first.  I'm cloning this bug for RHEL5 too.
Comment 6 Jay Greguske 2010-11-23 10:52:00 EST
Ben, did you (plan to) engage upstream at all with this patch?
Comment 7 RHEL Product and Program Management 2011-01-06 22:56:36 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 Suzanne Yeghiayan 2011-01-07 11:14:42 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 9 RHEL Product and Program Management 2011-02-01 00:30:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 10 RHEL Product and Program Management 2011-02-01 13:44:30 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 13 Laszlo Ersek 2011-09-06 08:58:30 EDT
Please see bug 656362 comment 5.

Note You need to log in before you can comment on or make changes to this bug.