Bug 63744 - licq-bin segfault when closing sometimes
licq-bin segfault when closing sometimes
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: licq (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 05:18 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-21 02:50:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-04-18 05:18:13 EDT
From Bugzilla Helper:  
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-9; Linux)  
  
Description of problem:  
Sometimes after using LICQ for a while, when I close LICQ it segfaults.  Here  
is the KDE trace.  
  
(no debugging symbols found)...(no debugging symbols found)...  
(no debugging symbols found)...(no debugging symbols found)...  
(no debugging symbols found)...[New Thread 1024 (LWP 2878)]  
[New Thread 2049 (LWP 2890)]  
[New Thread 1026 (LWP 2891)]  
[New Thread 2051 (LWP 2892)]  
[New Thread 3076 (LWP 2893)]  
(no debugging symbols found)...  
0x420b47f9 in wait4 () from /lib/i686/libc.so.6  
#0  0x420b47f9 in wait4 () from /lib/i686/libc.so.6  
#1  0x4213030c in __DTOR_END__ () from /lib/i686/libc.so.6  
#2  0x40126ca3 in waitpid () from /lib/i686/libpthread.so.0  
#3  0x4107a5c2 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4  
#4  0x40124f75 in pthread_sighandler () from /lib/i686/libpthread.so.0  
#5  <signal handler called>  
#6  0x408eecba in QBoxLayout::~QBoxLayout ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#7  0x408f0e64 in QVBoxLayout::~QVBoxLayout ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#8  0x409371da in QWidget::~QWidget () from /usr/lib/qt3/lib/libqt-mt.so.3  
#9  0x40a2c045 in QVGroupBox::~QVGroupBox ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#10 0x409371da in QWidget::~QWidget () from /usr/lib/qt3/lib/libqt-mt.so.3  
#11 0x402ad34c in UserEventCommon::~UserEventCommon ()  
   from /usr/lib/licq/licq_kde-gui.so  
#12 0x402b3144 in UserSendCommon::~UserSendCommon ()  
   from /usr/lib/licq/licq_kde-gui.so  
#13 0x402b6a84 in UserSendMsgEvent::~UserSendMsgEvent ()  
   from /usr/lib/licq/licq_kde-gui.so  
#14 0x4090a3f0 in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3  
#15 0x4093bed1 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3  
#16 0x408abff3 in QApplication::internalNotify ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#17 0x408abe8c in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3  
#18 0x40fdfeab in KApplication::notify () from /usr/lib/libkdecore.so.4  
#19 0x408ac90f in QApplication::sendPostedEvents ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#20 0x408ac78b in QApplication::sendPostedEvents ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#21 0x408506f3 in QApplication::processNextEvent ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#22 0x408ad4bc in QApplication::enter_loop ()  
   from /usr/lib/qt3/lib/libqt-mt.so.3  
#23 0x40850637 in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3  
#24 0x40232887 in CLicqGui::Run () from /usr/lib/licq/licq_kde-gui.so  
#25 0x4022f7fb in LP_Main () from /usr/lib/licq/licq_kde-gui.so  
#26 0x4022f4cf in LP_Main_tep () from /usr/lib/licq/licq_kde-gui.so  
#27 0x40121fef in pthread_start_thread () from /lib/i686/libpthread.so.0  
  
  
Version-Release number of selected component (if applicable):  
licq-1.1.0-0.cvs20020412.1  
licq-kde-1.1.0-0.cvs20020412.1  
  
How reproducible:  
Sometimes  
  
Steps to Reproduce:  
1. Use licq for a while.  
2. Close LICQ.  
 
Actual Results:    
Sometimes segfaults.  
  
Expected Results:    
Shouldn't segfault.
Comment 1 Warren Togami 2002-04-18 05:22:30 EDT
Oops, I forgot to mention the worst part about this bug.  After the segfault 
there are some leftover processes and the pid file. 
 
[warren@riku warren]$ ps ax |grep licq 
 2893 ?        Z      0:09 [licq-bin <defunct>] 
 2878 ?        T      0:00 /usr/lib/licq/licq-bin -p kde-gui 
 2890 ?        T      0:09 /usr/lib/licq/licq-bin -p kde-gui 
 2891 ?        T      0:00 /usr/lib/licq/licq-bin -p kde-gui 
 2892 ?        T      0:00 /usr/lib/licq/licq-bin -p kde-gui 
[warren@riku warren]$ licq 
23:18:06: [ERR] Licq: Already running at pid 2878. 
                      Kill process or remove /home/warren/.licq/licq.pid.
Comment 2 Warren Togami 2002-04-21 02:50:45 EDT
I forgot to mention that this is with kde-gui, with KDE systray and arts 
enabled.
Comment 3 Bernhard Rosenkraenzer 2002-08-05 10:49:44 EDT
Can't reproduce this with 1.2.0a-1. Please reopen if you're still having 
problems with that version.

Note You need to log in before you can comment on or make changes to this bug.