Bug 637447 - ATI display driver fails to work with new RHEL 5.5 kernel-2.6.18-194.11.4.el5.x86_64
ATI display driver fails to work with new RHEL 5.5 kernel-2.6.18-194.11.4.el5...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
Red Hat Kernel QE team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-25 17:45 EDT by Niksa Jurinovic
Modified: 2013-11-05 14:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 14:25:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Niksa Jurinovic 2010-09-25 17:45:57 EDT
Description of problem:

----
RHEL-5.5 for x86_64
HARDWARE: Intel S5520SC workstation motherboard with 2 x Intel XEON Quad core
Video Card: SAPHIRE ATI HD-4870 PCIe Video card 512 MB  
----

I've just upgraded from

kernel-2.6.18-194.11.3.el5.x86_64

to most current

kernel-2.6.18-194.11.4.el5.x86_64

and got the problem with ATI Catalyst display driver. Whenever I perform kernel upgrade, I have to recompile vendor-provided ATI display driver downloadable from AMD/ATI site, because system ATI driver, provided by RHEL, doesn't work properly (too slow). I did that hundred times and never had a problem. This time the problem is that after upgrading to new kernel and recompiling the existing ATI display driver (Revision 10.8), it doesn't work anymore, even though it worked perfectly with previous kernel. I cannot even start X11 (glibc problem reported with stack traces!!!). The newest ATI display driver (Revision 10.9) "works" with new kernel, but display is awfully slow making any serious work impossible. It is even slower than system-provided ATI driver. But I cannot start ATI Catalyst Control Center gui at all.

I am pretty sure the problem is in new kernel. When I switch back to previous kernel release (2.6.18-194.11.3), everything works properly and fast as before upgrading. ATI Catalyst Control Center gui starts without problem.

Version-Release number of selected component (if applicable):


How reproducible:

Download ATI Catalyst Display Driver Revision 10.9 from

http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.42&lang=English

build rpm binary package and install it, first with 2.6.18-194.11.3 kernel (everything works fine and fast), and then with 2.6.18-194.11.4 kernel (doesn't work properly, too slow, Catalyst Control Center gui cannot be started).

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Jackson 2013-11-05 14:25:59 EST
We can't fix bugs in Catalyst.

Note You need to log in before you can comment on or make changes to this bug.