Bug 63748 - pam_xauth doesn't copy correct cookie.
Summary: pam_xauth doesn't copy correct cookie.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pam   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-18 11:20 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 13:53:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-04-18 11:20:31 UTC
Description of Problem:

pam_xauth doesn't copy the cookie that is actually used by xlib.

Version-Release number of selected component (if applicable):
7.2 latest upgrades, as of 17th April 2002

How Reproducible:
4 Servers, all had exactly the same problem.

Steps to Reproduce:

1. 
Log in via ssh (with X tunneling)
2. 
Su to root "su -"
3. 
Try and run an X application.

Actual Results:
It fails, because the cookie hasn't been copied.

Expected Results:
X application should run.

Additional Information:
/etc/hosts
----------------------------------------------------------------------------
127.0.0.1 localhost.localdomain localhost
192.168.0.1 MachineName
----------------------------------------------------------------------------

Changes to sshd_config (openssh from openssh-3.1p1-2)
----------------------------------------------------------------------------
Protocol 2
PermitRootLogin no
PasswordAuthentication no
X11UseLocalHost yes
----------------------------------------------------------------------------

Unclear how much these affect the problem.

X11UseLocalHost causes only 1 xauth cookie to be set (instead of two).

Basically:

If you have DISPLAY set to localhost:10, then the cookie that is used is
MachineName/unix:10, pam_xauth doesn't copy this.

-Antony

Comment 1 Tomas Mraz 2004-10-21 13:53:51 UTC
It works just fine with Fedora Core 2.



Note You need to log in before you can comment on or make changes to this bug.