Bug 63755 - Missing Title Bar Text.
Summary: Missing Title Bar Text.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-18 12:50 UTC by David Edwards
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 10:04:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Edwards 2002-04-18 12:50:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
RedHat 7.2.93 ( Skipjack ) was installed and some Java compliance tests 
(mandated by Sun) related to setting text on title bar found not to work. Here 
are the observations made so far:

The version of GNOME desktop manager is the same as that of Redhat Advanced 
Server. However , when the display was exported to another linux machine 
(Debian) running with GNOME and sawfish ( the same version as this ), this 
defect was not observed. This indicatest that the defect does not appear to be 
affected by the window manager (sawfish).
It is also noticed that in the same configurations that the Java compliance 
test fails, Gnome Control Center does not display the text on its title bar.
RedHat 7.2.92 ( beta3 ) was also installed and while running the tests, we see 
the title bar text correctly. Gnome Control Center also shows the title on the 
title bar. So this failure is a regression moving from Beta 3 to Beta 4.

The softwares installed on the debian machine and RedHat Skipjack are:
X version 4.2.0 installed on RedHat Skipjack and X version 4.1.0 on Debian  ( 
versions of GNOME and Sawfish are the same ).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Type gnomecc at a command prompt.
2.Wait for the Gnome Control Centre to open.
3.
	

Actual Results:  The "Gnome Control Centre" text is missing from the title bar 
of the window.

Expected Results:  The text should be displayed.

Additional info:

We cannot demonstrate Java compliance on this release because the Java 
Compliance Kit test that writes a Title Bar fails.

Comment 1 Preston Brown 2002-04-18 14:55:20 UTC
 Probably not bugs in the Java implementation, but rather the window manager...

Comment 2 Havoc Pennington 2002-04-18 15:37:17 UTC
My prediction is that you have your locale set to iso885915 (cat
/etc/sysconfig/i18n, echo $LANG) and you don't have the latest Xlib
from our tree which understands this locale. To verify this theory, 
check ~/.xsession-errors for "locale not supported by Xlib" messages, and 
try changing your locale to just en_US (no encoding) or en_US.ISO-8859-1.
Or in gdm, select a different language from the default.

Havoc


Comment 3 Havoc Pennington 2002-07-06 02:03:25 UTC
Reopen if more details added.

Comment 4 David Edwards 2002-07-10 10:04:55 UTC
Once we got the GA version of Red Hat 7.3 the problem had disappeared.

Comment 5 Havoc Pennington 2002-07-10 13:28:51 UTC
Thanks


Note You need to log in before you can comment on or make changes to this bug.