Bug 63756 - mozilla startup page should depend on locale
Summary: mozilla startup page should depend on locale
Status: CLOSED DUPLICATE of bug 83105
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: indexhtml   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: web
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-18 12:55 UTC by Jens Petersen
Modified: 2007-04-18 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
localizeindex patch (507 bytes, patch)
2002-08-28 00:19 UTC, Leon Ho
no flags Details | Diff

Description Jens Petersen 2002-04-18 12:55:37 UTC
Description of Problem:
When starting up mozilla in a non-English locale, it should show
the index.html.<locale> page not the English one always.

Version-Release number of selected component (if applicable):
mozilla-0.9.9-7

Steps to Reproduce:
1. start mozilla in non-English locale the first time.

Actual Results:
Shows English index page.

Expected Results:
Non-English page for supported languages locale.

Additional Information:
I think this worked in Enigma

Comment 1 Christopher Blizzard 2002-04-18 17:31:36 UTC
This has never worked before.

Comment 2 Jens Petersen 2002-08-15 05:52:24 UTC
Of course this has nothing to do with mozilla. :-)

All that's needed is for indexhtml to generate a symbolic link from
/usr/share/doc/HTML/index.html to index.html.<DEFAULT_LOCALE>.

Comment 3 Leon Ho 2002-08-28 00:18:02 UTC
We can symlink to different localized version of index.html from mozilla wrapper:

- We can change index page location from redhatify patch in mozilla and ln -sf
to that location

- We can rename index.html to index.html.en_US and by default it points to
index.html.en_US

Following attachment is patch for the wrapper. Is it a good approach?

Comment 4 Leon Ho 2002-08-28 00:19:18 UTC
Created attachment 73424 [details]
localizeindex patch

Comment 5 Christopher Blizzard 2002-08-28 00:57:27 UTC
That's not going to work as a normal user is it?

Please keep in mind there's a much better way to do this.  The variable that
controls the home page is in the lang pack.  If I had lang packs, we could just
do it there instead.

Comment 6 Leon Ho 2002-08-28 01:03:48 UTC
We could link a file to ~/ or something, but agreed it is a bit dirty. Yes if
the lang pack have the variable that control it, it would be much cleaner to do
it over there.

Comment 7 Jens Petersen 2002-08-28 02:55:42 UTC
My original suggestion about the symlink is just for the system default.
Ie the default page language for the system would be determined by the system 
default locale when indexhtml is installed/upgraded.


Comment 8 Nakai 2002-08-28 06:19:52 UTC
We are using the latest mozilla that translatation teams have not followed
well yet, so it should not depend on lang pack.

For Mozilla 1.0.1, only Greek lang pack is available at this moment.

Comment 9 Nakai 2002-08-28 07:17:20 UTC
Can we set LANG value( the return value of setlocale(LC_MESSAGES, ""))
to Javascript's natigator.systemLanguage?

If so, we can redirect from index.html to each lang index.html.

Comment 10 Leon Ho 2003-01-31 00:21:05 UTC

*** This bug has been marked as a duplicate of 83105 ***

Comment 11 Red Hat Bugzilla 2006-02-21 18:48:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.