Bug 63771 - Boot loader attempts to install boot loader to USB floppy (/dev/sda)
Boot loader attempts to install boot loader to USB floppy (/dev/sda)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 12:56 EDT by Richard Black
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-18 18:00:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Black 2002-04-18 12:56:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Both lilo and grub attempt to install the boot loader to /dev/sda (usb floppy) 
vs. /dev/cciss/c0d0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use USB floppy to boot installer (bootnet.img) rh73-beta4
2. kernel loads and detects USB floppy
3. install completes normally

Actual Results:  Boot loader (both lilo and grub) attempts to install boot 
loader to /dev/sda which is the USB floppy (floppy is write protected).  System 
does not boot because there is no boot loader.

Expected Results:  Boot loader should have been installed to /dev/cciss/c0d0.

Additional info:

This problem exists in RH72 as well.
Comment 1 Michael Fulbright 2002-04-24 12:48:28 EDT
Jeremy we probably need code to avoid suggesting a block device that is
removable as the location of the MBR.
Comment 2 Jeremy Katz 2002-04-24 13:03:28 EDT
Booting with 'linux nousbstorage' should already work for both Hampton and
Pensacola and the 7.2 anaconda update disk by not loading the usb-storage
module, so that's at least a work-around for now.
Comment 3 Jeremy Katz 2002-05-06 20:15:15 EDT
Modified in CVS so that removable devices can't be the "MBR" unless you're using
expert mode
Comment 4 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.