Bug 63778 - resize up2date resizes password prompt panel
resize up2date resizes password prompt panel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 14:05 EDT by Gene Czarcinski
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-24 17:19:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-04-18 14:05:46 EDT
Description of Problem:
I resized the panel/window for update so I could see more of the list of
packages at one time.  The next time I ran up2date, the password prompt
panel/window came up to the resized values.

Version-Release number of selected component (if applicable):
7.2.93 plus up2date 2.7.77-7.x.3

How Reproducible:
every time

Steps to Reproduce:
1. run up2date and resize the panel/window
2. Then complete or terminate.
3. Run up2date again

Actual Results:
password prompt resized

Expected Results:
password prompt still the small "popup" panel.

Additional Information:
Comment 1 Adrian Likins 2002-04-18 14:23:42 EDT
I'm not sure I understand whats going...

Where are you launching up2date from?

who are you launching up2date as? ( I assume a user of
some sort, since otherwise userhelper would never prompt
for a password)

Which dialog do you resize?

Also which windowmanager is this running under? My guess
is there is some odd window manager or session manager behaviour
going on, as:

  - up2date doesnt keep track of window sizes itself
  - up2date doesnt actually display the password prompt, userhelper does...

Comment 2 Gene Czarcinski 2002-04-18 14:58:35 EDT
fresh install of 7.2 -> 7.2.93 upgrade -> XFree86 4.2.0-6.666 applied -> up2date
download rpm & up2date and then apply -> up2date all outstanding errata.

The system has gnome+kde+development+web server + samba+ other stuff... not an
everything install but lots of stuff.

From the Start Here menu: Programs->System->Update Agent

This is run as a regular user (not root).

PATH is standard.

When up2date is invoked, the first time the "smallish" password prompt comes up
and I enter root's password.  After up2date comes up, I resize it larger so I
can see more of the package list at one time.

The next time I run up2date, the password prompt is that same size that I
resized up2date to (lots of gray area).

Comment 3 Gene Czarcinski 2002-04-18 15:06:44 EDT
I have rhn registered as geneczarcinski with email address of genec@cox.rr.com.
 I just registered a second system and if you can bump my entitlements up 1 I
can try this system.

When I just tried to run up2date on this system, I got the small password prompt
but of course it did not run.  This is a basic gnome+kde system with no
development or servers.
Comment 4 Adrian Likins 2002-04-18 15:35:02 EDT
should have two more slots now...

talk to jrb, and he seems to agree that is
probabaly some sort of session manager issue, possibly related
to the window manager/desktop...

what wm/desktop are you using? I cant seem to duplicate
with fvwm/sawfish under gnome
Comment 5 Gene Czarcinski 2002-04-18 15:57:49 EDT
Running gnome/sawfish
Comment 6 Gene Czarcinski 2002-04-18 16:02:07 EDT
I have two systems defined to rhn: moscow.home (original entitlement) and have
added amber.home.  I just tried to change the profile for amber.home and was
told I do not have enough entitlements.
Comment 7 Gene Czarcinski 2002-04-19 11:35:39 EDT
OK, I was confused and had not realized that you added three "workgroup"
entitlements instead of increasing the number of "basic" entitlements.

I gave "moscow" a workgroup entitlement and ran the test.

The first time I ran up2date (from the Start Here menu), I got the smallish
password prompt and entered root's password.

During the up2date process of downloading and installing the errata rpm, I
increased the size of the up2date panel.  When I ran up2date again, the password
prompt was the size of the increased up2date panel.

This systems has gnome+kde installed ... no development and no servers (except
ssh).  I am running gnome/sawfish.

I then logged out and back in selecting kde session this time.  When I ran
up2date, I got a small password prompt.  When running up2date, I increased the
size of the up2date panel and did at least one "next" but did not finish.  I
then ran up2date agin but got a small password prompt!

I then logged out and back in with gnome/sawfish session.  I ran up2date and got
the increased size password prompt.

This prblem seems to be related only to gnome/sawfish!
Comment 8 Gene Czarcinski 2002-04-19 15:36:41 EDT
OK, I believe I have tracked down what is causing the behavior -- sawfish is
saving the placement and SIZE of the up2date window and using that for the
password prompt window too.

I setup two new userids (call them usera and userb).  The then logged on each,
used preferences to set sawfish window-placement.  In one case I selected to
first-fit positioning, ignore program specified positioning, and automatically
remember window attributes.  In the second case, I did the same but ADDED to
remember window size.

In the case where I specified to remember window size, it had the indicated
behavior.

In the case where remembering window size was NOT specified, up2date reverted
each time it ran.


I found the place where sawfish is saving the information in
~/.sawfish/window-history in the (dimension iiii jjjj).  When I deleted this,
the behavior reverrted to the small password prompt.

My guess is that the userhelper program (in the usermode package) does not set
the dimentions of the panel and just lets it default.  Sawfish fills them in
with the up2date values.

I don't know if this is a bug in usermods, something to be RFE'ed for usermode,
or "working as designed" (unfortunately).

Comment 9 Adrian Likins 2002-04-24 17:18:46 EDT
That sounds right.

Not sure if it's a sawfish bug or a usermode bug. Lets try
filling it against sawfish first (since it seems like sawfish
is guessing the window incorrectly...)

If sawfish is the wrong place, feel free to move it
to the approriate component.
Comment 10 Havoc Pennington 2002-04-24 17:53:37 EDT
Sawfish has some configuration options like "save window positions/sizes". This
option is really a bad idea, because there's no reliable way to recognize "the
same" window next time it appears. So to my knowledge (and I've just verified it) 
this option is disabled by default. You can find the options under "Placement"
in the Sawfish configuration. If you have anything about remembering window
features checked, turn it off.

If that wasn't the problem please reopen the bug.

Calling this NOTABUG since Sawfish is working as designed though I agree this 
aspect of the design is broken.

Note You need to log in before you can comment on or make changes to this bug.