Bug 63782 - wins lookup problems
Summary: wins lookup problems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-18 18:21 UTC by bryan hunt
Modified: 2007-04-18 16:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 09:36:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bryan hunt 2002-04-18 18:21:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)

Description of problem:
They only work for ping and traceroute they wont work for telnet or ssh

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.In /etc/nsswitch.conf set lookup line to hosts: wins files dns nisplus
2.Go to a command line and attempt to ping a windows box on your network 
ie: ping skippy .....
[root@localhost glibc]# ping skippy
PING skippy (192.168.0.244) from 192.168.0.6 : 56(84) bytes of data.
64 bytes from 192.168.0.244: icmp_seq=1 ttl=255 time=0.614 ms

--- skippy ping statistics ---
1 packets transmitted, 1 received, 0% loss, time 0ms
rtt min/avg/max/mdev = 0.614/0.614/0.614/0.000 ms

3. That worked no problem 

4 Now try to telnet to the same box ....
 telnet skippy
telnet: skippy: No address associated with hostname
skippy: No address associated with name 

Actual Results:  telnet should have connected to the server

Expected Results:  telnet could not find the hostname however ping was able to do so

Additional info:

RPMS installed 

samba-2.2.3a-4
samba-common-2.2.3a-4
samba-client-2.2.3a-4
samba-swat-2.2.3a-4
telnet-0.17-20
net-tools-1.60-3

Comment 1 Andrew Bartlett 2002-04-23 03:05:13 UTC
I think sombody added the getaddrinfo fn recently (which is what this bug
describes - its currently missing).

Try a samba_2_2 CVS checkout.  See pserver.samba.org



Comment 2 bryan hunt 2002-04-26 11:03:15 UTC
I have gotten the latest samba source (-r samba_2_2 ) and can confirm that the 
function getaddrinfo is not there (i did a grep on the source). I did however 
compile and install the libnss_wins.o module into the /lib directory and tried 
again ... still no sucess .

--B

Comment 3 Trond Eivind Glomsrxd 2002-04-26 15:42:19 UTC
Keeping open... 2.2.4 should be out soonish.

Comment 4 Andrew Bartlett 2002-05-06 09:27:02 UTC
2.2.4 didn't include the fix.  Sorry about that - if I had actually checked the
code I probably would have been able to get a fix in.  The odd bit is, we did
actually have this functionality (as least I think I remember the commit
message) at one stage...

This is important to get right, so I'll try to track down the fix (a patch did
cross the lists a few months ago) - but if sombody wants to send me one it can't
do any harm :-)

This would be worth patching in Redhat's RPM before the next release if possible.

Comment 5 Andrew Bartlett 2002-06-03 13:05:04 UTC
OK, looks like jerry had picked this one up, and it will be in 2.2.4.  The patch
has been commited to the tree this time :-).  

A new release (the last for 2.2, we hope) is flagged for the end of the week, so
this bug should be well on the way to being wrapped up!

http://www.samba.org/cgi-bin/cvsweb/samba/source/nsswitch/wins.c?r1=1.4.4.21&r2=1.4.4.22

Comment 6 bryan hunt 2002-06-04 09:36:47 UTC
Many thanks to all involved  
 
--Bryan

Comment 7 Trond Eivind Glomsrxd 2002-07-24 16:59:02 UTC
We have 2.2.5 in rawhide currently, with this fix. Closing.


Note You need to log in before you can comment on or make changes to this bug.