Bug 637847 - NetworkManager fails to work on XFCE4
Summary: NetworkManager fails to work on XFCE4
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-27 15:26 UTC by Horst H. von Brand
Modified: 2013-01-13 14:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-27 21:48:40 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2010-09-27 15:26:55 UTC
Description of problem:
I switched to XFCE4 when Gnome went south, and had no network:

- nm-applet shows the "enable..." buttons greyed out
- Only DHCP configuration of eth0 works, the (default, static) configuration for it doesn't work
- Running "iwconfig wlan0 essid <something>" says in /var/log/messages that the configuration was OK, but running it again shows no configuration took place
- Futzing around with iw is the same (only more confusing)

I'm running systemd

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-6.git20100831.fc15.x86_64
xfce4-session-4.6.2-1.fc14.x86_64
systemd-10-5.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start XFCE4 session
2.
3.
  
Actual results:
NetworkManager does nothing

Expected results:
Working network

Additional info:

Comment 1 Michael Spahn 2010-09-27 16:15:25 UTC
Reporter, could you please describe us what you have done to get to this point, and how we can reproduce this issue here? Is there anything special about your system, network, configuration which we need to replicate here in order to reproduce your problem please?

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Horst H. von Brand 2010-09-27 21:20:34 UTC
I used switchdesk (text) to go to XFCE4, and configured:

/etc/sysconfig/desktop:
DISPLAYMANAGER=XDM

This because Gnome (at least GDM) was thoroughly broken.

I had used XFCE4 on and off before in rawhide in this machine.

My network configuration (via NetworkManager) is just a wired connection with static parameters (IPv4 address, default router, fixed nameserver), I occasionally use "Auto eth0" (wired network at home or elsewhere with DHCP). A bunch of WiFi networks I've configured over time moving around, the WiFi network (no security) at home and here at work. Plus one VPN (connected to a Cisco router).

The wired connection "Auto eth0" (not the static configuration!) usually works, and once after getting that going WiFi "magically" worked too, but that was just once (and I played around restarting all services I thought might have some bearing: dbus, avahi, NetworkManager), but couldn't get it to work again later.

Comment 3 Michael Spahn 2010-09-27 21:48:40 UTC
Hello,

first, thank you for your efforts.

I think this isn't a bug of NetworkManager itself, but maybe you are missing packages or something like that.

At the moment I would say, there went something terrible wrong with the time.

I suggest you to ask in fedoraforum.org or one of the Fedora support IRC channels.

Hope you can fix it. :-)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Michael Spahn 2010-09-27 21:49:44 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.