Bug 63792 - /etc/init.d/ipchains stop should rmmod ipchains
/etc/init.d/ipchains stop should rmmod ipchains
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ipchains (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 15:35 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 19:41:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-18 15:35:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
When you do a /etc/init.d/ipchiains stop it leaves the ipchains module still
running.  So if you stop ipchains and try to start iptables, iptables will not
start because iptables rc script does an lsmod and exits if it sees the ipchains
modules still running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/ipchains stop
2.  lsmod | grep ipchains
3.
	

Actual Results:  ipchains was still running.

Expected Results:  ipchains should not have shown up in a lsmod.

Additional info:

Try running /etc/init.d/iptables start after
/etc/init.d/ipchains stop and you will see
that iptables will not start up will the ipchains modules is still loaded.
Comment 1 Mike A. Harris 2002-04-19 05:30:08 EDT
Sounds reasonable.  The iptables script should probably do the same
with iptables modules.
Comment 2 kenneth_porter 2002-05-08 19:41:29 EDT
Will rmmod remove dependent modules?

I'm thinking of the connection-tracking suite. It 
would also be nice if there were an /etc/sysconfig file to control which tracking modules were 
loaded.
Comment 3 Mike A. Harris 2002-05-22 06:07:16 EDT
I've added an rmmod to the ipchains script at the end of the "stop"
section.  It's currently untested so I don't know how well it works,
but that should turn up in beta testing.

If anyone would like it done in iptables' initscript also, file a separate
request against iptables.

ipchains 1.3.10-14
Comment 4 kenneth_porter 2002-05-22 21:44:13 EDT
FYI, iptables bug has been entered as bug 65389.
Comment 5 James Manning 2002-05-23 12:47:50 EDT
probably better done as modprobe -r instead of rmmod in case there's a set of
dependent modules that would also be best removed later on

Note You need to log in before you can comment on or make changes to this bug.