This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 637929 - dhclient-script does "ip link set eth0 down" and after that dhclient fails with -ENETDOWN
dhclient-script does "ip link set eth0 down" and after that dhclient fails wi...
Status: CLOSED DUPLICATE of bug 574568
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-27 14:59 EDT by Sami Farin
Modified: 2010-09-30 07:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 07:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Farin 2010-09-27 14:59:17 EDT
Description of problem:

Sep 21 16:07:14 safari dhclient[9612]: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 37
Sep 21 16:07:14 safari dhclient[9612]: send_packet: Network is down

Sep 27 15:25:56 safari dhclient[29077]: No working leases in persistent database - sleeping.
Sep 27 15:26:01 safari dhclient[29077]: receive_packet failed on eth0: Network is down

script should be a teeny bit smarter in handling cases
EXPIRE|FAIL|RELEASE|STOP and TIMEOUT

Version-Release number of selected component (if applicable):
4.2.0-7

How reproducible:
always

Steps to Reproduce:
1. start dhclient
2. fail to get IP address from DHCP server on first try
3.
  
Actual results:
link stays down

Expected results:
dhclient manages to send something

Additional info:
Comment 1 Jiri Popelka 2010-09-29 12:17:48 EDT
Seems similar to bug #574568.

But I'm not able to reproduce that (maybe it's hardware related problem).
Can you better describe the steps to reproduce ?
Is this (4.2.0-7.fc14) the first time you see this problem ?

DHCP servers, relays, and clients all should be able to
transmit and receive a UDP packet on an unconfigured interface (in order to speak the DHCP protocol in strict compliance with RFC2131).
So bringing the interface down shouldn't be a problem.
Comment 2 Sami Farin 2010-09-30 04:33:51 EDT
did you get to step 2 ?
you should have "${reason}" TIMEOUT or FAIL.

I have also PERSISTENT_DHCLIENT=yes
and I have also ONBOOT=no or otherwise bootup stalls for some minutes when network is not working during boot.

"unconfigured interface" is not the same as "interface down".
when interface is down, you get
write(5, "...", 342) = -ENETDOWN (Network is down)
Comment 3 Jiri Popelka 2010-09-30 07:18:22 EDT
(In reply to comment #2)
> "unconfigured interface" is not the same as "interface down".
> when interface is down, you get
> write(5, "...", 342) = -ENETDOWN (Network is down)
You are right.

*** This bug has been marked as a duplicate of bug 574568 ***

Note You need to log in before you can comment on or make changes to this bug.