Bug 637978 - gnome-terminal crashes at random
gnome-terminal crashes at random
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-27 17:45 EDT by Horst H. von Brand
Modified: 2010-11-30 09:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 09:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Excerpt from /var/log/messages showing the crash. The Python program that went down was yum. (25.83 KB, text/plain)
2010-09-27 17:45 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2010-09-27 17:45:26 EDT
Created attachment 450048 [details]
Excerpt from /var/log/messages showing the crash. The Python program that went down was yum.

Description of problem:
Running Gnome. I usually have two gnome-terminals open, one with some 8 tabs (local) and the other (remote) normally with just one.

On the local one I run a root shell (updating the system via yum, sundry sysadminning like checking if outgoing mail did in fact leave) and a few other local shells (getting git, kernel sources; local work; getting/compiling Stone Soup). On the remote I've an ssh running to a remote system, and a screen(1) there. I usually start xemacs and xpdf from some of the "local work" tabs.

When I leave the machine for longer time (say an hour or so for a meeting or classes) the screensaver kicks in. Sometimes in this situation (longer absences, never short ones) I came back and the gnome-terminals are both gone.

Version-Release number of selected component (if applicable):
gnome-terminal-2.31.91-1.fc15.x86_64
yum-3.2.28-8.fc15.noarch
python-2.7-11.fc15.x86_64

How reproducible:
Seems to happen to yum when left running on its own under screensaver (I usually start it before going away for a while, as its disk activity makes the system nearly unusable when mass getting/updating)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Horst H. von Brand 2010-11-30 09:44:06 EST
Hasn't happened again. Seems to have been due to kernel OOM misbehaving.

Note You need to log in before you can comment on or make changes to this bug.