Bug 638103 - Second monitor not enabled on F14 live CD by default
Second monitor not enabled on F14 live CD by default
Status: CLOSED DUPLICATE of bug 638174
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-09-28 05:22 EDT by Greg Wildman
Modified: 2010-09-28 21:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-09-28 21:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output of the xrandr command (36.07 KB, application/x-gzip)
2010-09-28 05:22 EDT, Greg Wildman
no flags Details

  None (edit)
Description Greg Wildman 2010-09-28 05:22:13 EDT
Created attachment 450129 [details]
Output of the xrandr command

Description of problem:
Multihead not working on live CD. 'xrandr' command shows second monitor but it is not enabled. Second monitor is shown in gnome-display-properties but is not enabled. Running test for Test Day as per  https://fedoraproject.org/wiki/QA:Testcase_nouveau_multihead

Version-Release number of selected component (if applicable):

How reproducible:
Every time I use the live CD (desktop-x86_64-20100927.15.iso)

Steps to Reproduce:
1. Boot from Fedora 14 x86_64 live CD (desktop-x86_64-20100927.15.iso)
2. run gnome-display-properties and enable second monitor
Actual results:
The second monitor stays off (no signal). 

Expected results:
The second monitor should be on during boot and after login. The desktop should be spanned across the two monitors.

Additional info:
- Smolt profile: http://www.smolts.org/client/show/pub_e7e80fe4-c516-46ad-8858-5c10e251f4c4
- no /etc/X11/xorg.conf file used.
- Attachment includes: gdm-0.log gregw_xrandr.log Xorg.0.log
Comment 1 Greg Wildman 2010-09-28 06:04:53 EDT
To test the GLX for Test Day, https://fedoraproject.org/wiki/QA:Testcase_nouveau_glx, I installed mesa-dri-drivers-experimental, glx-utils, desktop-effect and compiz-gnome.

I turned on the effects (Wobbly windows and desktop cube). I ran gnome-display-properties again and enabled the second monitor. This time it worked. The rotating cube now has both desktops and the second monitor is active.

I will test again with the desktop effects off.
Comment 2 Greg Wildman 2010-09-28 06:32:55 EDT
I rebooted the live CD image (no desktop effects). I noticed this time that plymouth correctly used the second monitor (mirrored). GDM login was with the second monitor blank. Login as the liveuser and still no second monitor. Running gnome-display-properties showed the monitor and this time when I enabled it and clicked 'apply' it came on.

The results are different from this initial testing. I will leave the laptop off for an hour and test again.
Comment 3 Greg Wildman 2010-09-28 08:24:11 EDT
Laptop powered off for 1 hour. Test was the same as last test.

1. Plymouth enables both monitors in a mirrored configuration.
2. As soon as gdm changes the background and provides the login the second monitor goes off.
3. After login, running gnome-display-properties and enabling the second screen it works as expected.

Now I am not sure if the first test was accurate. Anyways the current problem is that the second monitor is not enabled by default.
Comment 4 Ben Skeggs 2010-09-28 21:05:36 EDT

*** This bug has been marked as a duplicate of bug 638174 ***

Note You need to log in before you can comment on or make changes to this bug.