Bug 638415 - Failed to connect to the session manager
Failed to connect to the session manager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-28 19:34 EDT by Brandon
Modified: 2010-10-08 18:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 18:13:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brandon 2010-09-28 19:34:37 EDT
Description of problem:


[brandon@localhost ~]$ su -c 'gedit /etc/pulse/daemon.conf'
Password: 

(gedit:3873): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
[brandon@localhost ~]$ 


*trying to edit pulse .conf for 5.1 surround sound. used vim instead.
Comment 1 Matthias Clasen 2010-10-08 18:13:47 EDT
Not a bug, at least not a gedit bug. If you run it as root, it doesn't have access to your session bus, and thus neither session management nor gio functionality are available.

Note You need to log in before you can comment on or make changes to this bug.