Bug 638423 - Guake has wrong terminal type set (environment variable TERM=dumb)
Guake has wrong terminal type set (environment variable TERM=dumb)
Status: CLOSED DUPLICATE of bug 639280
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-09-28 19:41 EDT by Aron Parsons
Modified: 2010-10-13 14:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-10-13 14:58:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Aron Parsons 2010-09-28 19:41:55 EDT
Description of problem:
Shells run in Guake have their terminal type set to dumb (environment variable TERM=dumb).  Running xterm or gnome-terminal has the correct TERM environment variable set).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. set guake as a startup application in GNOME
2. open a new shell in Guake
3. echo $TERM
Actual results:

Expected results:

Additional info:
I have Guake set to automatically start in GNOME.  If I kill that instance and start Guake from gnome-terminal, the TERM variable is set correctly.  So maybe this is an issue with GNOME and not necessarily Guake?
Comment 1 Pierre-YvesChibon 2010-10-10 07:33:30 EDT
It appears to be a VTE bug cf: http://guake.org/ticket/249#comment:10

I am therefore reassigning this bug to VTE.
According to qense on the Guake bug tracker there is a patch available at:
Comment 2 Kevin Fenzi 2010-10-13 14:58:39 EDT
This looks like a dup of 639280

*** This bug has been marked as a duplicate of bug 639280 ***

Note You need to log in before you can comment on or make changes to this bug.