Bug 638457 - virt manager won't start due to pygobject
Summary: virt manager won't start due to pygobject
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pygobject2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-29 03:23 UTC by darrell pfeifer
Modified: 2010-10-18 17:51 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 17:51:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description darrell pfeifer 2010-09-29 03:23:40 UTC
Description of problem:

ERROR:root:could not import gobject (could not find _PyGObject_API object)
Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 420, in <module>
    main()
  File "/usr/share/virt-manager/virt-manager.py", line 290, in main
    import gtk
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 40, in <module>
    from gtk import _gtk
ImportError: could not import gobject (could not find _PyGObject_API object)
Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 427, in <module>
    _show_startup_error(str(run_e), "".join(traceback.format_exc()))
  File "/usr/share/virt-manager/virt-manager.py", line 61, in _show_startup_error
    import gtk
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 40, in <module>
    from gtk import _gtk
ImportError: could not import gobject (could not find _PyGObject_API object)



Version-Release number of selected component (if applicable):

virt-manager.noarch           0.8.5-1.fc15

gobject-introspection.x86_64  0.9.7-1.fc15                                      
pygobject2.x86_64             2.26.0-3.fc15

Comment 1 Shawn Starr 2010-10-16 17:02:58 UTC
This continues 

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 420, in <module>
    main()
  File "/usr/share/virt-manager/virt-manager.py", line 347, in main
    from virtManager.engine import vmmEngine
  File "/usr/share/virt-manager/virtManager/engine.py", line 41, in <module>
    from virtManager.details import vmmDetails
  File "/usr/share/virt-manager/virtManager/details.py", line 33, in <module>
    from virtManager.console import vmmConsolePages
  File "/usr/share/virt-manager/virtManager/console.py", line 27, in <module>
    import gtkvnc
ImportError: could not import gobject (could not find _PyGObject_API object)


virt-manager-0.8.5-1.fc15.noarch
pygobject2-2.26.0-4.fc15.x86_64
gobject-introspection-0.9.12-1.fc15.x86_64

Comment 2 Daniel Berrange 2010-10-18 09:36:45 UTC
Looks like pygobject is totally fubar to me, re-assigning.

Comment 3 Colin Walters 2010-10-18 17:00:32 UTC
Should be fixed in the latest pygobject.

Comment 4 darrell pfeifer 2010-10-18 17:09:24 UTC
As with comment 1, I have 2.26.0-4.fc15 which is the latest from Sept 30.

I also have a completely updated rawhide and the bug/problem is still there.

Comment 5 Colin Walters 2010-10-18 17:22:18 UTC
Ah, the last gtk-vnc happened to be built with 2.20.0-3 which was a temporary API break for python2

* Tue Sep 28 2010 John (J5) Palmieri <johnp@redhat.com> - 2.26.0-3
- add patch to work with PyCapsule since PyCObject is removed from 
  Python 3.2 which we ship in rawhide

Which was then reverted for Python 2 here:

* Thu Sep 30 2010 John (J5) Palmieri <johnp@redhat.com> - 2.26.0-4
- Edit PyCapsule patch to only use PyCapsule in Python 3.x
  since this effects header files which require other modules to 
  be recompiled.  There is actually discussion upstream to undeprecate it
  for the 2.x series

I'll queue a gtk-vnc rebuild now which should fix this.

Comment 6 darrell pfeifer 2010-10-18 17:43:33 UTC
Installed gtk-vnc 0.4.1-9 from koji. It fixes the problem of virt manager at least starting.

When I try to run my old f13 virtual machine I get:


Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 878, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1321, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Process exited while reading console log output: Supported machines are:
pc         Standard PC (alias of pc-0.13)
pc-0.13    Standard PC (default)
pc-0.12    Standard PC
pc-0.11    Standard PC, qemu 0.11
pc-0.10    Standard PC, qemu 0.10
isapc      ISA-only PC

Should I close this bug as complete and enter a new one, or is this a continuation of the same problem?

Comment 7 Colin Walters 2010-10-18 17:51:20 UTC
Marking as fixed in http://koji.fedoraproject.org/koji/buildinfo?buildID=200949

Comment 8 Colin Walters 2010-10-18 17:51:52 UTC
(In reply to comment #6)

> Should I close this bug as complete and enter a new one, or is this a
> continuation of the same problem?

Looks like a different bug to me.


Note You need to log in before you can comment on or make changes to this bug.