Bug 6385 - ftpd needs SUPPORT_BROKEN_CLIENTS as ftp install and mc are broken
Summary: ftpd needs SUPPORT_BROKEN_CLIENTS as ftp install and mc are broken
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-26 14:09 UTC by Oleg Makarenko
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 16:17:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oleg Makarenko 1999-10-26 14:09:11 UTC
-Symptoms:
Ftp upgrade from wu-ftp-2.6.0-1 server hangs after reading
hdlist. mc-4.5.39-0.91 also hangs after copying file.

Workaround:
wu-ftpd-2.5 works fine and 2.6.0 recompiled with
SUPPORT_BROKEN_CLIENTS works fine too.

Conclusion:
So ftp upgrade and mc seems to be the "broken clients" that
wu-ftpd-2.6 has workaround for but that workaround
unfortunatly was not compiled into wu-ftpd-2.6.0-1 update.

Comment 1 Gilbert E. Detillieux 1999-10-26 20:39:59 UTC
There are other broken clients out there too.  For example, mirror
2.9, for which the following patch has been provided...

ftp://ftp.wu-ftpd.org/pub/support/wu-ftpd-2.6.0-mirror-2.9.patch

Eventually, all of those packages should be fixed (since they're the
broken ones).  Updating ftpd again, to re-break the protocol, seems
like the wrong way to go, but it may be a reasonable short-term
compromise if a lot of useful clients are broken.

Comment 2 furiorh 2000-01-14 15:51:59 UTC
This remedy (defining SUPPORT_BROKEN_CLIENTS) also solved
a similar case opened today by one of our customers, using the
standard ftp client available from the DOS prompt on a Windoze
box. We use wu-ftpd-2.6.0-1.i386.rpm on RH 6.0.

furio ercolessi/ Spin

Comment 3 Bernhard Rosenkraenzer 2000-01-18 16:17:59 UTC
We won't compile wu-ftpd with support for broken clients, as it causes
instabilities in the transfers.
See the various wu-ftpd readmes.

Comment 4 Anonymous 2000-01-18 17:20:59 UTC
You are right. But nobody claims you should support broken clients. The point is
that you must support all ftp clients that come with your own product. So you
should either fix all broken clients shipped with RedHat 6.1 and make the update
available *simultaneously* to wu-ftpd update or use SUPPORT_BROKEN_CLIENTS as a
workaround. Otherwise you simply broke the working things instead of improving
them.

For example after wu-ftpd update RH6.1 ftp installation doesn't work anymore and
THAT is the bug. If you don't like SUPPORT_BROKEN_CLIENTS then fix ftp install
(and all other broken ftp clients shipped with RedHat if any).

Best regards,
Oleg


Note You need to log in before you can comment on or make changes to this bug.