Bug 63851 - Can't boot from USB floppy
Can't boot from USB floppy
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: dosfstools (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-19 11:27 EDT by Roy Kimbrell
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:30:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible fix (641 bytes, patch)
2002-06-18 00:30 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Roy Kimbrell 2002-04-19 11:27:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
Sony Vaio does not have an IDE floppy, but the BIOS supports booting from a USB
floppy.  This works with DOS/Win, but does not with a linux boot disk (made
using qmkbootdisk).  (I made the boot floppy by moving /dev/fd3 to /dev/fd3.old
and creating a soft link to /dev/fd3 from /dev/sda (the USB floppy).  Then I ran
qmkbootdisk (from the Gnome menu).)  Upon restarting the machine, the floppy
gets accessed, but the BIOS(?) or bootloader(?) reports "Boot failed."  

Version-Release number of selected component (if applicable):  Linux 2.4.9-31


How reproducible:  Always

Steps to Reproduce:
1.  Attach USB floppy drive
2.  Make boot disk
3.  Reboot
	


Actual Results:  "Boot failed"

Expected Results:  regular boot

Additional info:

This is low priority since I can boot using the CDROM if I ever have to boot
using some external medium.
Comment 1 Roy Kimbrell 2002-04-19 16:23:50 EDT
The bootloader is Grub.
Comment 2 Pete Zaitcev 2002-06-03 13:29:35 EDT
Grabbing the bug

Comment 3 Pete Zaitcev 2002-06-10 12:06:04 EDT
I never heard of qmkbootdisk, so I have two questions.

First, please run this for me:  rpm -qf $(which qmkbootdisk)
It should provide the RPM name.

Second, does mkbootdisk work? It should take --device argument,
so you do not need to rename anything in /dev.
Comment 4 Roy Kimbrell 2002-06-10 16:02:30 EDT
#rpm -qf $(which qmkbootdisk)
kdeadmin-2.2.2-3

Oops.  You're right about mkbootdisk.  I ran

#/sbin/mkbootdisk --device /dev/sda 2.4.9-34

which created a floppy boot disk in my USB floppy - at least the floppy drive
made noises and mkbootdisk didn't complain.

Rebooted.

Just after the Sony logo disappeared from the screen at startup I got a

Boot failed

message.  Same as before.

Regards,
Roy
Comment 5 Pete Zaitcev 2002-06-10 20:20:48 EDT
mkbootdisk calls mkdosfs and syslinux. On a USB floppy,
which is a SCSI device, mkdosfs gets wrong geometry, stores
it into BIOS parameters area, and confuses syslinux.
Comment 6 H. Peter Anvin 2002-06-10 20:26:25 EDT
USB floppes look like hard disks to mkdosfs.  This is probably the most
fundamental problem.  This is really a USB (SCSI, really) driver problem.

mkdosfs and its handling of the geometry is pretty sick.  I've had as a
backburner project to rewrite mkdosfs from the ground up, but haven't had time.
Comment 7 Pete Zaitcev 2002-06-18 00:30:53 EDT
Created attachment 61345 [details]
Possible fix
Comment 8 rehbein 2002-11-06 11:59:00 EST
I have the exact same problem with a sony vaio, trying to boot from a USB
floppy. Except I am running redhat V8.0. Can this patch be applied to the 8.0
sources? Or is there a different fix available for 8.0
carl
Comment 9 Bill Nottingham 2006-08-07 16:06:39 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 10 Bill Nottingham 2006-10-18 13:30:13 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.