Bug 638538 - ISE: Pushing sha256 rpm with old rhnpush
ISE: Pushing sha256 rpm with old rhnpush
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: 462714 640131
  Show dependency treegraph
 
Reported: 2010-09-29 05:52 EDT by Šimon Lukašík
Modified: 2014-07-04 09:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 640131 (view as bug list)
Environment:
Last Closed: 2014-07-04 09:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2010-09-29 05:52:39 EDT
Description of problem:
Pushing rpms with sha256 to the satellite with old fashion rhnpush leads to ISE.

Version-Release number of selected component (if applicable):
rhnpush-5.3.1-5.el5sat
sat540

How reproducible:
deterministic

Steps to Reproduce:
1. Take latest rhnpush from rhel5
2. Take some sha256 rpm (for inst. from fedora13)
3. Make push to Satellite 540.
  
Actual results:
[snip from rhnpush]
Internal server error 500 Internal Server Error
Error pushing /tmp/perl-DBIx-Class-0.08108-1.fc12.noarch.rpm: Error 500Error Message:
    Mismatching information
Error Class Code: 104
Error Class Info: (500)

[snip from rhn_upload_package_push.log]
2010/09/29 05:12:30 -04:00 15919 0.0.0.0: package_push/package_push.handler('Mismatching checksums: expected', 'md5', '737e0c2bf6d211fb0740a2615de8862c', '; got:', 'sha256', '19a67cbc88cfb4f42c6273c3b608d514257a6b2beea7b733f74a2521afebeb82')


Expected results:
Not ISE

Additional info:
This is regression against Satellite 530. Pushing these packages with old tool against Satellite530 works as expected.
Comment 1 Clifford Perry 2010-10-04 17:35:54 EDT
I wish to have this added into the Release Notes for Satellite 5.4.0 within the Known Issues section. I will move this bug to sat600-triage and clone this bug, aligned to sat540-docs. A statement similar to:

Due to changes for SHA256 feature, old rhnpush clients are not compatible with RHN Satellite 5.4. When attempting to upload Red Hat Enterprise Linux 6 compatible content, use the newest rhnpush to avoid errors being generated. 



Cliff.

Note You need to log in before you can comment on or make changes to this bug.