Bug 63860 - lpr does not print to network print server
lpr does not print to network print server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-19 13:44 EDT by Ian Prowell
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 09:14:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Prowell 2002-04-19 13:44:41 EDT
Description of Problem:
When printing to a network print server print jobs immediatly show up as done
from a skipjack beta 2 system, but works fine from 6.2-7.2 systems.

Version-Release number of selected component (if applicable):
LPRng-3.8.9-3

How Reproducible:
Always, even with RedHat 7.2 version of LPRng (LPRng-3.7.4-28)

Steps to Reproduce:
1. Install skipjack-beta2 with patches for locale and GNUCash
2. Setup a lpd network printer with printconf-gui (D-Link DP101 print server
attached to a HP DeskJet 400). 
3. Try to print

Actual Results:
File does not print, but appears to have printed.  See below.

[iprowell@hiro iprowell]$ lpr mozilla.ps 
[iprowell@hiro iprowell]$ lpq
Printer: inky@hiro (dest inky@inky.prowell.org.bogus)
 Queue: no printable jobs in queue
 Server: no server active
 Status: job 'iprowell@hiro+43' saved at 10:40:27.804
 Rank   Owner/ID                  Class Job Files                 Size Time
done   iprowell@hiro+43             A    43 mozilla.ps           99147 10:40:27

Port Name          INKY
==============================
[Total Status]
Job                12
Sizes (KBytes)     1172
Timeouts           0
------------------------------
[Current Job]     
Printer Status     On line      
Index              0
Protocol                          
Name                              
Spooling Bytes     0
Printing Bytes     0
==============================
[iprowell@hiro iprowell]$ lpr mozilla.ps 
[iprowell@hiro iprowell]$ lpq
Printer: inky@hiro (dest inky@inky.prowell.org.bogus)
 Queue: no printable jobs in queue
 Server: no server active
 Status: job 'iprowell@hiro+62' saved at 10:40:38.137
 Rank   Owner/ID                  Class Job Files                 Size Time
done   iprowell@hiro+43             A    43 mozilla.ps           99147 10:40:27
done   iprowell@hiro+62             A    62 mozilla.ps           99147 10:40:37

Port Name          INKY
==============================
[Total Status]
Job                13
Sizes (KBytes)     1172
Timeouts           0
------------------------------
[Current Job]     
Printer Status     On line      
Index              0
Protocol                          
Name                              
Spooling Bytes     0
Printing Bytes     0
==============================

Expected Results:
Printout to come out from the printer.

Additional Information:
If the same file is printed to the same printer from a RedHat 7.2 system there
is no problem.  Setting up LPR to print through the 7.2 machine results in the
same problem (ie skipjack beta2 -> 7.2 -> DP101).
Comment 1 Tim Waugh 2002-05-07 03:39:56 EDT
I see the file you are printing is 'mozilla.ps'---if you take the output 
generated from Mozilla on Red Hat Linux 7.2, and print that from a Red Hat 
Linux 7.3 system, does _that_ work?  Also, does the output from Mozilla on Red 
Hat Linux 7.3, when printed from a Red Hat Linux 7.2 system, work?
Comment 2 Ian Prowell 2002-05-07 21:45:48 EDT
The problem is not specific to Mozilla.  It occurs with OpenOffice, LaTex, etc.
 To answer your question though, if I copy a postscript file generated on the
Skipjack system to a RedHat 7.2 system I am able to print the file.  When a file
generated on a RedHat 7.2 system is copied to the Skipjack system the results
are the same as trying to print locally.  I am currently working on installing
7.3 to see if the problem still exists.  If so I will enter the bug under 7.3 as
it probably does not make sense to fix issues in Skipjack now.
Comment 3 Ian Prowell 2002-05-08 00:00:32 EDT
This problem persists in 7.3 so I am moving the bug to the 7.3 release.
Comment 4 Gordon Messmer 2002-06-11 00:06:40 EDT
I was having this problem, too.  The latest LRPng errata fixed this problem for me.
Comment 5 Ian Prowell 2002-06-11 00:57:09 EDT
Thanks for the suggestion.  The new version of LPRng did not initially solve my
problems, but a quick visit to linuxprinting.org made me realize that the pcl3
driver has replaced the hpdj print driver.  When I switched to the pcl3 driver
everything started working.  I though I had tried all driver versions for the
DJ400 in the previous version of LPRng, but things are solved now.  Might be
worth while removing the hpdj driver as an option for a DeskJet 400 in
printconf-gui.  Once again thanks.  It is time to start upgrading the other
workstations since this was the last issue that was keeping me back from 7.3!
Comment 6 Need Real Name 2002-07-04 09:13:02 EDT
The "fix" implied here pertains only to the particular driver (hpdj vs. pcl3).
We have a similar problem here, but it is with the "postscript" driver to an
HPJL2100M printer with external JetDirect print server. Same printer and files
work on RedHat v7.2 and fail on *some* RedHat v7.3 installations. A hand-made
printcap entry (/etc/printcap.local) that uses no filters and sends directly to
the printer works fine, but normal definitions built with printtool (both
JetDirect and LPR/LPD) do not. I will try alternate (non-postscript) drivers,
but after that I will yank out all print-related RPMs and install their analogs
from v7.2 if I can't find any other way to fix this annoying (and serious) bug.
Comment 7 Tim Waugh 2002-07-04 10:04:36 EDT
Please first try downgrading printconf to the one that shipped with 7.2, or 
else the one that was issued as an update for 7.2.  I'd like to be sure that 
the bug is somewhere in printconf. 
 
I haven't been able to reproduce this here, but I have heard other people have 
had the same problem.
Comment 8 Tim Waugh 2004-12-08 09:14:42 EST
Closing since we use CUPS now instead of LPRng.

Note You need to log in before you can comment on or make changes to this bug.