Bug 638645 - [RFE] - Change Satellite API call users.listUsers
[RFE] - Change Satellite API call users.listUsers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
: FutureFeature, Triaged
: 638658 (view as bug list)
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2010-09-29 11:17 EDT by Chris Williams
Modified: 2012-03-08 04:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 638658 723017 (view as bug list)
Environment:
Last Closed: 2011-07-19 04:18:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Williams 2010-09-29 11:17:26 EDT
1. Customer Name: Comcast 
2. What is the nature and description of the request? Enhancement to RHN API users.listUsers 
3. Why does the customer need this? (List the business requirements here): Easier management of RHN accounts. 
4. How would the customer like to achieve this? (List the functional requirements here): Currently users.listUsers does not provide any indication if an account is disabled or not. Customer would like it to either not list disabled users, or, include a field indicating 'disabled'. 
5. For each functional requirement listed in question 4, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented. Invoke users.listUsers against an RHN account that has disabled users associated with it. Verify that it either does not list the disabled users, or that it indicates which users are disabled. 
6. Is there already an existing RFE upstream or in Red Hat bugzilla? Not that I was able to find. 
7. How quickly does this need resolved? (desired target release) Customer would like to have this asap, though I wouldn't consider it critical. Next major release? 
8. Does this request meet the RHEL Inclusion criteria (please review) Not RHEL. If we get this in RHN Satellite, would it also get into RHN hosted? 
9. List the affected packages RHN, RHN Satellite
Comment 1 Grant Gainey 2010-10-04 15:25:37 EDT
This is a Satellite RFE - moving to the Satellite component.

RE response to 8, above - no, Satellite changes do not affect Hosted.
Comment 2 Tomas Lestach 2010-10-07 04:49:11 EDT
*** Bug 638658 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Lestach 2011-07-19 04:18:24 EDT
I see an 'enabled' attribute of this API was implemented already in Feb 6 2009.

It's definitely part of Satellite 5.4.0:
http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/API_Overview/handlers/UserHandler.html#listUsers

According to
http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3/html/API_Overview/handlers/UserHandler.html#listUsers
it shall be also part of Satellite 5.3.x

spacewalk.git/satellite.git: 3913d2ad34f55e37013cb4613bba351fd3c03476

Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.