Bug 63868 - error: cannot create %sourcedir /usr/src/redhat/SOURCE
error: cannot create %sourcedir /usr/src/redhat/SOURCE
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-19 15:55 EDT by Gene Czarcinski
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-25 12:51:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-04-19 15:55:50 EDT
Description of Problem:
On a fresh install 7.2.93 system (with up2date-2.7.77-7.x.3 applied), I
configured to download but do not install and download source.  Both binary and
source rpms were downloaded but at the end, the error message given in the
summary was issued.



Version-Release number of selected component (if applicable):
7.2.93 NO development installed.

How Reproducible:
yes

Steps to Reproduce:
1. see above
2. 
3. 

Actual Results:
got error message

Expected Results:
no error message

Additional Information:
Comment 1 Adrian Likins 2002-04-24 16:36:00 EDT
hmm, I'm a little stumped.

The error looks like something I would expect to see when
attempting to install a source rpm (possibly without rpm-build installed
maybe?)

But... even when told to install, up2date doesnt install the source rpms. 
Moreso when it's told not to install, so I'm a little confused.

What packages were you downloading when it did this?

is /usr or /usr/src readonly? Do you have any custom
rpm macros defined for that machine?
Comment 2 Gene Czarcinski 2002-04-25 09:21:16 EDT
I was downlaoding usermode.  I had the up2date config set to download source and
also set to NOT install anything.

I believe (don't know for sure) the error is the result of up2date checking to
see that all appropriate conditions exist to install packages (even src.rpm).

The system in question has NO development installed (such as rpm-build).
Comment 3 Adrian Likins 2002-04-25 12:51:47 EDT
Trying it with no rpm-build installed on a 7.2 or beta box doesnt
seem to trigger it for me. But those are also fairly full installs
otherwise. 

I'll try it on a -devel free box today and see if I can trigger
it...

Note You need to log in before you can comment on or make changes to this bug.