This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 638735 - unable to pxe boot a virtual machine without hitting ctrl-b
unable to pxe boot a virtual machine without hitting ctrl-b
Status: CLOSED DUPLICATE of bug 586324
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-29 15:17 EDT by Michael Gregg
Modified: 2014-08-05 07:17 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-04 16:53:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2010-09-29 15:17:26 EDT
Description of problem:
When trying to pxe boot a vm, dhcp times out if I do not hit ctrl-b to break the boot sequence. 
This issue seems to be reported in: 
https://bugzilla.redhat.com/show_bug.cgi?id=472236

Version-Release number of selected component (if applicable):
qemu-0.12.5-1.fc13.x86_64
virt-manager-0.8.5-1.fc13.noarch

How reproducible:
most boots

Steps to Reproduce:
1. start virtual machine
2. when you are prompted to press CTRL-B do it
3. try to get dhcp address running this command: dhcp net0
4. repeat step 3 until you do not get address (reply "ok")
5. boot using command: autoboot
  
Actual results:
dhcp fails on most boots
Comment 1 Jan ONDREJ 2010-09-30 00:46:12 EDT
Same problem here.

I have an better workaround. Instead of typing so many characters, try to select from virt-manager menu Send Key -> Ctrl Alt Delete.

You can do this aprox. 2-3 seconds after guest was started, do not need to wait for DHCP timeout.

I think component should be changed to gpxe, because it looks that gpxe DHCP timeout should be increased by 3 seconds to fix this problem.
Comment 2 Michael Gregg 2010-10-05 18:53:51 EDT
I discovered that if I lower the bridge forward delay to 5 sec, pxe booting starts working again.

Set it with:
brctl setfd br0 5
Comment 3 Jan ONDREJ 2010-10-06 02:21:40 EDT
(In reply to comment #2)
> I discovered that if I lower the bridge forward delay to 5 sec, pxe booting
> starts working again.
> 
> Set it with:
> brctl setfd br0 5

I can confirm this on my system.
Comment 4 Paul Jenner 2011-03-04 16:26:09 EST
So this is a duplicate of bug #586324 - DHCP fails for bridges with long forward delay
Comment 5 Michael Gregg 2011-03-04 16:51:41 EST
that's correct. I'll make this bug a duplicate.
Comment 6 Michael Gregg 2011-03-04 16:53:30 EST
Again, for clarification, the work-around seems to be running:

brctl setfd <bridge device> 3 

This bug now marked as duplicate of #586324

*** This bug has been marked as a duplicate of bug 586324 ***

Note You need to log in before you can comment on or make changes to this bug.