Bug 638892 - Retrieving stored compressed integer, float, and boolean values fails
Summary: Retrieving stored compressed integer, float, and boolean values fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php-pecl-memcache
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-30 09:55 UTC by Robert Vogelgesang
Modified: 2011-05-19 14:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 14:29:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to clear the compression flag for integer, float, and boolean data (817 bytes, patch)
2010-09-30 09:55 UTC, Robert Vogelgesang
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0794 0 normal SHIPPED_LIVE php-pecl-memcache bug fix and enhancement update 2011-05-18 18:08:11 UTC

Description Robert Vogelgesang 2010-09-30 09:55:50 UTC
Created attachment 450704 [details]
Patch to clear the compression flag for integer, float, and boolean data

Description of problem:
php-pecl-memcache has a bug preventing the successful storage of integer, float,
or boolean values in memcached.

Version-Release number of selected component (if applicable):
php-5.3.2-4.el6.x86_64
php-pecl-memcache-3.0.4-3.2.el6.2.x86_64
memcached-1.4.4-3.el6.x86_64

How reproducible:
Always when storing and retrieving integer, float, or boolean values, with compression enabled.

Steps to Reproduce:
Example scripts that reproduce the bug can be found in upstreams bug tracker at:
http://pecl.php.net/bugs/bug.php?id=16442
  
Actual results:
Retrieving a stored value fails, the stored value is lost, and PHP logs a message with level NOTICE:
MemcachePool::get(): Failed to uncompress data

Expected results:
Retrieving a stored value should succeed and return the stored value.

Additional info:
The upstream author changed php-pecl-memcache so that compression is never used to store values of integer, float, and boolean types, but forgot to clear the compression flag in case it should be set.  Because of this, values that were stored this way fail decompression on retrieval, because they are not compressed in the first place.

The attached patch fixes the issue.

Comment 2 Robert Vogelgesang 2010-10-06 11:43:24 UTC
Upstream has released version 3.0.5 which contains the fix from the patch attached to this Bugzilla entry.  Please upgrade to the latest version.

Comment 3 Joe Orton 2010-11-13 21:08:48 UTC
Thanks for reporting this.

Comment 4 RHEL Program Management 2011-01-07 15:52:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 9 Denise Dumas 2011-04-07 15:17:32 UTC
Had to clear Rebase keyword to keep bot from resetting relnote flag - there is a relnote for this rebase, it is just attached to another bug fixed by the rebase

Comment 11 errata-xmlrpc 2011-05-19 14:29:43 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0794.html


Note You need to log in before you can comment on or make changes to this bug.